5321A C++ API Manual: JY5321ACore.h File Reference

5321A C++ API Manual Generated 2026-05-28 from CHM/5321A/C++
  • Main Page
  • Classes
  • Files
  • File List
  • File Members
Classes | Typedefs | Enumerations | Functions
JY5321ACore.h File Reference

Classes

struct ScalingCoefficients

Typedefs

typedef void * JY5321A_DeviceHandle

Enumerations

enum | JY5321A_AI_RawDataWidth { JY5321A_AI_RawDataWidth_Auto = 0 , JY5321A_AI_RawDataWidth_16bits = 1 , JY5321A_AI_RawDataWidth_32bits = 2 }
enum | JY5321A_AI_BandWidth { JY5321A_AI_BandWidth_25K = 0x0 , JY5321A_AI_BandWidth_220K = 0x1 }
enum | JY5321A_AI_SampleMode { JY5321A_AI_Finite = 0x0 , JY5321A_AI_Continuous = 0x1 , JY5321A_AI_Single = 0x2 }
enum | JY5321A_CI_SampleMode { JY5321A_CI_Finite = 0x0 , JY5321A_CI_Continuous = 0x1 , JY5321A_CI_Single = 0x2 }
enum | JY5321A_CO_OUTMode { JY5321A_CO_Finite = 0x0 , JY5321A_CO_ContinuousWrapping = 0x1 , JY5321A_CO_ContinuousNoWrapping = 0x2 , JY5321A_CO_Single = 0x3 }
enum | JY5321A_AI_TriggerType { JY5321A_AI_Immediately = 0x0 , JY5321A_AI_Digital = 0x1 , JY5321A_AI_Analog = 0x2 , JY5321A_AI_Soft = 0x3 }
enum | JY5321A_CIO_TriggerType { JY5321A_CIO_Immediately = 0x0 , JY5321A_CIO_Soft = 0x1 , JY5321A_CIO_Digital = 0x2 }
enum | JY5321A_TriggerMode { JY5321A_StartTrigger = 0x0 , JY5321A_ReferenceTrigger = 0x1 }
enum | JY5321A_DigitalTriggerEdge { JY5321A_Rising = 0x0 , JY5321A_Falling = 0x1 }
enum JY5321A_DigitalTriggerSource {
JY5321A_PFI0 = 0 , JY5321A_PFI1 = 1 , JY5321A_PFI2 = 2 , JY5321A_PFI3 = 3 ,
JY5321A_PFI4 = 4 , JY5321A_PFI5 = 5 , JY5321A_PFI6 = 6 , JY5321A_PFI7 = 7 ,
JY5321A_PFI8 = 8 , JY5321A_PFI9 = 9 , JY5321A_PFI10 = 10 , JY5321A_PFI11 = 11 ,
JY5321A_PFI12 = 12 , JY5321A_PFI13 = 13 , JY5321A_PFI14 = 14 , JY5321A_PFI15 = 15 ,
JY5321A_PFI16 = 16 , JY5321A_PFI17 = 17 , JY5321A_PFI18 = 18 , JY5321A_PFI19 = 19 ,
JY5321A_PFI20 = 20 , JY5321A_PFI21 = 21 , JY5321A_PFI22 = 22 , JY5321A_PFI23 = 23 ,
JY5321A_PFI24 = 24 , JY5321A_PFI25 = 25 , JY5321A_PFI26 = 26 , JY5321A_PFI27 = 27 ,
JY5321A_PFI28 = 28 , JY5321A_PFI29 = 29 , JY5321A_PFI30 = 30 , JY5321A_PFI31 = 31 ,
JY5321A_PXI_Trig0 = 32 , JY5321A_PXI_Trig1 = 33 , JY5321A_PXI_Trig2 = 34 , JY5321A_PXI_Trig3 = 35 ,
JY5321A_PXI_Trig4 = 36 , JY5321A_PXI_Trig5 = 37 , JY5321A_PXI_Trig6 = 38 , JY5321A_PXI_Trig7 = 39 ,
JY5321A_Inter_AI_StartTrig = 40 , JY5321A_Inter_AI_ReferenceTrig = 41 , JY5321A_Inter_CIO_0_StartTrig = 42 , JY5321A_Inter_CIO_1_StartTrig = 43 ,
JY5321A_Inter_Counter_0_Output = 44 , JY5321A_Inter_Counter_1_Output = 45 , JY5321A_Inter_DI_StartTrig = 46 , JY5321A_Inter_DI_ReferenceTrig = 47 ,
JY5321A_Inter_DO_StartTrig = 48
}
enum JY5321A_AnalogTriggerSource {
JY5321A_Channel_0 = 0 , JY5321A_Channel_1 = 1 , JY5321A_Channel_2 = 2 , JY5321A_Channel_3 = 3 ,
JY5321A_Channel_4 = 4 , JY5321A_Channel_5 = 5 , JY5321A_Channel_6 = 6 , JY5321A_Channel_7 = 7 ,
JY5321A_Channel_8 = 8 , JY5321A_Channel_9 = 9 , JY5321A_Channel_10 = 10 , JY5321A_Channel_11 = 11 ,
JY5321A_Channel_12 = 12 , JY5321A_Channel_13 = 13 , JY5321A_Channel_14 = 14 , JY5321A_Channel_15 = 15 ,
JY5321A_Channel_16 = 16 , JY5321A_Channel_17 = 17 , JY5321A_Channel_18 = 18 , JY5321A_Channel_19 = 19 ,
JY5321A_Channel_20 = 20 , JY5321A_Channel_21 = 21 , JY5321A_Channel_22 = 22 , JY5321A_Channel_23 = 23 ,
JY5321A_Channel_24 = 24 , JY5321A_Channel_25 = 25 , JY5321A_Channel_26 = 26 , JY5321A_Channel_27 = 27 ,
JY5321A_Channel_28 = 28 , JY5321A_Channel_29 = 29 , JY5321A_Channel_30 = 30 , JY5321A_Channel_31 = 31
}
enum | JY5321A_MultiChannelCompositionLogic { JY5321A_Or = 0 , JY5321A_And = 1 }
enum | JY5321A_AnalogWindowCondition { JY5321A_Entering = 0x0 , JY5321A_Leaving = 0x1 }
enum | JY5321A_AnalogTriggerEdge { JY5321A_RisingSlope = 0x0 , JY5321A_FallingSlope = 0x1 }
enum | JY5321A_SampleClockSource { JY5321A_InternalSampleClock = 0x0 , JY5321A_ExternalSampleClock = 0x1 }
enum JY5321A_ExternalSampleClockTerminal {
JY5321A_SampleClock_PFI_0 = 0 , JY5321A_SampleClock_PFI_1 = 1 , JY5321A_SampleClock_PFI_2 = 2 , JY5321A_SampleClock_PFI_3 = 3 ,
JY5321A_SampleClock_PFI_4 = 4 , JY5321A_SampleClock_PFI_5 = 5 , JY5321A_SampleClock_PFI_6 = 6 , JY5321A_SampleClock_PFI_7 = 7 ,
JY5321A_SampleClock_PFI_8 = 8 , JY5321A_SampleClock_PFI_9 = 9 , JY5321A_SampleClock_PFI_10 = 10 , JY5321A_SampleClock_PFI_11 = 11 ,
JY5321A_SampleClock_PFI_12 = 12 , JY5321A_SampleClock_PFI_13 = 13 , JY5321A_SampleClock_PFI_14 = 14 , JY5321A_SampleClock_PFI_15 = 15 ,
JY5321A_SampleClock_PFI_16 = 16 , JY5321A_SampleClock_PFI_17 = 17 , JY5321A_SampleClock_PFI_18 = 18 , JY5321A_SampleClock_PFI_19 = 19 ,
JY5321A_SampleClock_PFI_20 = 20 , JY5321A_SampleClock_PFI_21 = 21 , JY5321A_SampleClock_PFI_22 = 22 , JY5321A_SampleClock_PFI_23 = 23 ,
JY5321A_SampleClock_PFI_24 = 24 , JY5321A_SampleClock_PFI_25 = 25 , JY5321A_SampleClock_PFI_26 = 26 , JY5321A_SampleClock_PFI_27 = 27 ,
JY5321A_SampleClock_PFI_28 = 28 , JY5321A_SampleClock_PFI_29 = 29 , JY5321A_SampleClock_PFI_30 = 30 , JY5321A_SampleClock_PFI_31 = 31 ,
JY5321A_SampleClock_PXI_Trig_0 = 32 , JY5321A_SampleClock_PXI_Trig_1 = 33 , JY5321A_SampleClock_PXI_Trig_2 = 34 , JY5321A_SampleClock_PXI_Trig_3 = 35 ,
JY5321A_SampleClock_PXI_Trig_4 = 36 , JY5321A_SampleClock_PXI_Trig_5 = 37 , JY5321A_SampleClock_PXI_Trig_6 = 38 , JY5321A_SampleClock_PXI_Trig_7 = 39 ,
JY5321A_Inter_AI_SampleClock = 40 , JY5321A_Inter_CI_0_SampleClock = 41 , JY5321A_Inter_CI_1_SampleClock = 42 , JY5321A_Inter_CO_0_Output = 43 ,
JY5321A_Inter_CO_1_Output = 44 , JY5321A_Clock_DI_SampleClock = 45 , JY5321A_Clock_DO_SampleClock = 46
}
enum JY5321A_Signal_Source {
JY5321A_Signal_PFI_0 = 0 , JY5321A_Signal_PFI_1 = 1 , JY5321A_Signal_PFI_2 = 2 , JY5321A_Signal_PFI_3 = 3 ,
JY5321A_Signal_PFI_4 = 4 , JY5321A_Signal_PFI_5 = 5 , JY5321A_Signal_PFI_6 = 6 , JY5321A_Signal_PFI_7 = 7 ,
JY5321A_Signal_PFI_8 = 8 , JY5321A_Signal_PFI_9 = 9 , JY5321A_Signal_PFI_10 = 10 , JY5321A_Signal_PFI_11 = 11 ,
JY5321A_Signal_PFI_12 = 12 , JY5321A_Signal_PFI_13 = 13 , JY5321A_Signal_PFI_14 = 14 , JY5321A_Signal_PFI_15 = 15 ,
JY5321A_Signal_PFI_16 = 16 , JY5321A_Signal_PFI_17 = 17 , JY5321A_Signal_PFI_18 = 18 , JY5321A_Signal_PFI_19 = 19 ,
JY5321A_Signal_PFI_20 = 20 , JY5321A_Signal_PFI_21 = 21 , JY5321A_Signal_PFI_22 = 22 , JY5321A_Signal_PFI_23 = 23 ,
JY5321A_Signal_PFI_24 = 24 , JY5321A_Signal_PFI_25 = 25 , JY5321A_Signal_PFI_26 = 26 , JY5321A_Signal_PFI_27 = 27 ,
JY5321A_Signal_PFI_28 = 28 , JY5321A_Signal_PFI_29 = 29 , JY5321A_Signal_PFI_30 = 30 , JY5321A_Signal_PFI_31 = 31 ,
JY5321A_Signal_PXI_Trig_0 = 32 , JY5321A_Signal_PXI_Trig_1 = 33 , JY5321A_Signal_PXI_Trig_2 = 34 , JY5321A_Signal_PXI_Trig_3 = 35 ,
JY5321A_Signal_PXI_Trig_4 = 36 , JY5321A_Signal_PXI_Trig_5 = 37 , JY5321A_Signal_PXI_Trig_6 = 38 , JY5321A_Signal_PXI_Trig_7 = 39 ,
JY5321A_AI_StartTrig = 40 , JY5321A_AI_ReferenceTrig = 41 , JY5321A_AI_SyncSignal = 42 , JY5321A_AI_SampleClock = 43 ,
JY5321A_CIO_0_StartTrig = 44 , JY5321A_CIO_1_StartTrig = 45 , JY5321A_CI0_SampleClock = 46 , JY5321A_CI1_SampleClock = 47 ,
JY5321A_CO_0_Output = 48 , JY5321A_CO_1_Output = 49 , JY5321A_CIO_100MHz = 50 , JY5321A_CIO_5MHz = 51 ,
JY5321A_CIO_100kHz = 52 , JY5321A_AnalogTrigger = 53 , JY5321A_DI_SampleClock = 54 , JY5321A_DI_StartTrig = 55 ,
JY5321A_DI_ReferenceTrig = 56 , JY5321A_DO_SampleClock = 57 , JY5321A_DO_StartTrig = 58
}
enum JY5321A_Signal_Destination {
JY5321A_PFI0_OUT = 0 , JY5321A_PFI1_OUT = 1 , JY5321A_PFI2_OUT = 2 , JY5321A_PFI3_OUT = 3 ,
JY5321A_PFI4_OUT = 4 , JY5321A_PFI5_OUT = 5 , JY5321A_PFI6_OUT = 6 , JY5321A_PFI7_OUT = 7 ,
JY5321A_PFI8_OUT = 8 , JY5321A_PFI9_OUT = 9 , JY5321A_PFI10_OUT = 10 , JY5321A_PFI11_OUT = 11 ,
JY5321A_PFI12_OUT = 12 , JY5321A_PFI13_OUT = 13 , JY5321A_PFI14_OUT = 14 , JY5321A_PFI15_OUT = 15 ,
JY5321A_PFI16_OUT = 16 , JY5321A_PFI17_OUT = 17 , JY5321A_PFI18_OUT = 18 , JY5321A_PFI19_OUT = 19 ,
JY5321A_PFI20_OUT = 20 , JY5321A_PFI21_OUT = 21 , JY5321A_PFI22_OUT = 22 , JY5321A_PFI23_OUT = 23 ,
JY5321A_PFI24_OUT = 24 , JY5321A_PFI25_OUT = 25 , JY5321A_PFI26_OUT = 26 , JY5321A_PFI27_OUT = 27 ,
JY5321A_PFI28_OUT = 28 , JY5321A_PFI29_OUT = 29 , JY5321A_PFI30_OUT = 30 , JY5321A_PFI31_OUT = 31 ,
JY5321A_PXITrig0_OUT = 32 , JY5321A_PXITrig1_OUT = 33 , JY5321A_PXITrig2_OUT = 34 , JY5321A_PXITrig3_OUT = 35 ,
JY5321A_PXITrig4_OUT = 36 , JY5321A_PXITrig5_OUT = 37 , JY5321A_PXITrig6_OUT = 38 , JY5321A_PXITrig7_OUT = 39 ,
JY5321A_None = 40
}
enum | JY5321A_DI_SampleMode { JY5321A_DI_Finite = 0x0 , JY5321A_DI_Continuous = 0x1 , JY5321A_DI_Single = 0x2 }
enum | JY5321A_DI_TriggerType { JY5321A_DI_Immediately = 0x0 , JY5321A_DI_Digital = 0x1 , JY5321A_DI_Soft = 0x3 }
enum | JY5321A_DO_UpdateMode { JY5321A_DO_Finite = 0x0 , JY5321A_DO_ContinuousWrapping = 0x1 , JY5321A_DO_ContinuousNoWrapping = 0x2 , JY5321A_DO_Single = 0x3 }
enum | JY5321A_DO_TriggerType { JY5321A_DO_Immediately = 0x0 , JY5321A_DO_Digital = 0x1 , JY5321A_DO_Soft = 0x3 }
enum | JY5321A_OutputType { JY5321A_Logic = 0 , JY5321A_OCGate = 1 }
enum | JY5321A_CountTimeBase { JY5321A_Internal_Timebase_100M = 0x0 , JY5321A_Internal_Timebase_5M = 0x1 , JY5321A_Internal_Timebase_100K = 0x2 , JY5321A_External_Timebase = 0x3 }
enum | JY5321A_CountDirection { JY5321A_CI_Count_Up , JY5321A_CI_Count_Down , JY5321A_CI_Count_External }
enum JY5321A_CI_MeasureType {
JY5321A_CI_EdgeCount = 0 , JY5321A_CI_Measure_FrequencyOrPeriod = 1 , JY5321A_CI_Measure_PulseWidth = 2 , JY5321A_CI_Measure_SemiPeriod = 3 ,
JY5321A_CI_Measure_EdgeSeparation = 4 , JY5321A_CI_EncoderX1 = 5 , JY5321A_CI_EncoderX2 = 6 , JY5321A_CI_EncoderX4 = 7 ,
JY5321A_CI_EncoderTwoPulse = 8
}
enum JY5321A_InputTerminal {
JY5321A_IN_PFI0 = 0 , JY5321A_IN_PFI1 = 1 , JY5321A_IN_PFI2 = 2 , JY5321A_IN_PFI3 = 3 ,
JY5321A_IN_PFI4 = 4 , JY5321A_IN_PFI5 = 5 , JY5321A_IN_PFI6 = 6 , JY5321A_IN_PFI7 = 7 ,
JY5321A_IN_PFI8 = 8 , JY5321A_IN_PFI9 = 9 , JY5321A_IN_PFI10 = 10 , JY5321A_IN_PFI11 = 11 ,
JY5321A_IN_PFI12 = 12 , JY5321A_IN_PFI13 = 13 , JY5321A_IN_PFI14 = 14 , JY5321A_IN_PFI15 = 15 ,
JY5321A_IN_PFI16 = 16 , JY5321A_IN_PFI17 = 17 , JY5321A_IN_PFI18 = 18 , JY5321A_IN_PFI19 = 19 ,
JY5321A_IN_PFI20 = 20 , JY5321A_IN_PFI21 = 21 , JY5321A_IN_PFI22 = 22 , JY5321A_IN_PFI23 = 23 ,
JY5321A_IN_PFI24 = 24 , JY5321A_IN_PFI25 = 25 , JY5321A_IN_PFI26 = 26 , JY5321A_IN_PFI27 = 27 ,
JY5321A_IN_PFI28 = 28 , JY5321A_IN_PFI29 = 29 , JY5321A_IN_PFI30 = 30 , JY5321A_IN_PFI31 = 31 ,
JY5321A_IN_PXI_Trig0 = 32 , JY5321A_IN_PXI_Trig1 = 33 , JY5321A_IN_PXI_Trig2 = 34 , JY5321A_IN_PXI_Trig3 = 35 ,
JY5321A_IN_PXI_Trig4 = 36 , JY5321A_IN_PXI_Trig5 = 37 , JY5321A_IN_PXI_Trig6 = 38 , JY5321A_IN_PXI_Trig7 = 39 ,
JY5321A_IN_AI_SampleClock = 40 , JY5321A_IN_CO_0_Output = 41 , JY5321A_IN_CO_1_Output = 42 , JY5321A_IN_CIO_100MHz = 43 ,
JY5321A_IN_CIO_5MHz = 44 , JY5321A_IN_CIO_100kHz = 45 , JY5321A_IN_DI_SampleClock = 46 , JY5321A_IN_DO_SampleClock = 47
}
enum | JY5321A_CI_SampleClock { JY5321A_CI_ImplicitClock = 0 , JY5321A_CI_InternalClock = 1 , JY5321A_CI_ExternalClock = 2 }
enum | JY5321A_CI_CounterEventSignalIdleState { JY5321A_CI_CounterEventSignalIdleState_Low = 0 , JY5321A_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JY5321A_LevelState { JY5321A_LowLevel = 0 , JY5321A_HighLevel = 1 }
enum | JY5321A_CI_ValueReturnMode { JY5321A_CI_ReturnTwoValue = 0 , JY5321A_CI_ReturnOneValue = 1 }
enum | JY5321A_CI_StartingEdge { JY5321A_RisingEdge = 0 , JY5321A_FallingEdge = 1 , JY5321A_AnyEdge = 2 }
enum | JY5321A_CO_IdleState { JY5321A_CO_LowLevel = 0 , JY5321A_CO_HighLevel = 1 }
enum | JY5321A_CO_PauseTrigger_OutState { JY5321A_CO_HoldOn = 0x0 , JY5321A_CO_HighOut = 0x1 , JY5321A_CO_LowOut = 0x2 }
enum | JY5321A_ReferenceClockSource { JY5321A_InternalRefClock = 0 , JY5321A_ExternalRefClock = 0x1 }
enum JY5321A_ExternalReferenceClockTerminal {
JY5321A_RefClock_PFI_0 = 0 , JY5321A_RefClock_PFI_1 = 1 , JY5321A_RefClock_PFI_2 = 2 , JY5321A_RefClock_PFI_3 = 3 ,
JY5321A_RefClock_PFI_4 = 4 , JY5321A_RefClock_PFI_5 = 5 , JY5321A_RefClock_PFI_6 = 6 , JY5321A_RefClock_PFI_7 = 7 ,
JY5321A_RefClock_PFI_8 = 8 , JY5321A_RefClock_PFI_9 = 9 , JY5321A_RefClock_PFI_10 = 10 , JY5321A_RefClock_PFI_11 = 11 ,
JY5321A_RefClock_PFI_12 = 12 , JY5321A_RefClock_PFI_13 = 13 , JY5321A_RefClock_PFI_14 = 14 , JY5321A_RefClock_PFI_15 = 15 ,
JY5321A_RefClock_PFI_16 = 16 , JY5321A_RefClock_PFI_17 = 17 , JY5321A_RefClock_PFI_18 = 18 , JY5321A_RefClock_PFI_19 = 19 ,
JY5321A_RefClock_PFI_20 = 20 , JY5321A_RefClock_PFI_21 = 21 , JY5321A_RefClock_PFI_22 = 22 , JY5321A_RefClock_PFI_23 = 23 ,
JY5321A_RefClock_PFI_24 = 24 , JY5321A_RefClock_PFI_25 = 25 , JY5321A_RefClock_PFI_26 = 26 , JY5321A_RefClock_PFI_27 = 27 ,
JY5321A_RefClock_PFI_28 = 28 , JY5321A_RefClock_PFI_29 = 29 , JY5321A_RefClock_PFI_30 = 30 , JY5321A_RefClock_PFI_31 = 31 ,
JY5321A_PXIe_Clk100 = 32
}
enum | JY5321A_OutputCompleteState { JY5321A_Zero = 0x0 , JY5321A_Hold = 0x1 }

Functions

JY5321A_API int | JY5321A_Open (int slotNumber, JY5321A_DeviceHandle *hDevice)
Open the 5321A series boards using the slot number or the board serial number. PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.
JY5321A_API int | JY5321A_OpenByAliasName (const char *aliasName, JY5321A_DeviceHandle *hDevice)
Open this 5321A series boards using the board alias name which is set by JYTEK utility JYDM. You can change the name using JYDM.
JY5321A_API int | JY5321A_Close (JY5321A_DeviceHandle hDevice)
Close this 5321A board.
JY5321A_API int | JY5321A_GetDeviceID (JY5321A_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. The 5321A is a series of boards.
JY5321A_API int | JY5321A_GetDeviceSerialNumber (JY5321A_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY5321A_API int | JY5321A_SetDeviceReferenceClock (JY5321A_DeviceHandle hDevice, JY5321A_ReferenceClockSource clockSource, JY5321A_ExternalReferenceClockTerminal terminal, double refclockFrequency)
Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis. PCIe device only supports 25MHz timebase.
JY5321A_API int | JY5321A_GetDeviceTemperature (JY5321A_DeviceHandle hDevice, double *temprature, double *fgpaTemprature)
get the device temprature.
JY5321A_API int | JY5321A_SignalRouting (JY5321A_DeviceHandle hDevice, JY5321A_Signal_Source sourceSignal, JY5321A_Signal_Destination destination, JY5321A_OutputType outputType, bool invertOutput)
Route a singal from source to destination. Both source and destination are defined by the corresponding enum Y5321A_SourceSignal and JY5321A_DestinationSignal. One source signal may be routed to multiple destinations.
JY5321A_API int | JY5321A_DisconnectSignalRouting (JY5321A_DeviceHandle hDevice, JY5321A_Signal_Destination destination)
Disconnect an established routing.
JY5321A_API int | JY5321A_SetDeviceStatusLed (JY5321A_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY5321A_API int | JY5321A_AI_EnableChannel (JY5321A_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY5321A_AI_BandWidth *bandWidth)
Enable AI channels. Each channel can be independently configured.
JY5321A_API int | JY5321A_AI_SetMode (JY5321A_DeviceHandle hDevice, JY5321A_AI_SampleMode mode)
Set AI sampling mode.
JY5321A_API int | JY5321A_AI_SetSampleRate (JY5321A_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. The sampling rate is the same for all channels.
JY5321A_API int | JY5321A_AI_SetSamplesToAcquire (JY5321A_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.
JY5321A_API int | JY5321A_AI_SetDSMode (JY5321A_DeviceHandle hDevice, bool enable)
Set AI DSMode enable,if enable, the AI bandwidth must be 220KHz for 5321 5311 5321B 5311B. default : disable(false).
JY5321A_API int | JY5321A_AI_Start (JY5321A_DeviceHandle hDevice)
Start AI acquisition.
JY5321A_API int | JY5321A_AI_ReadData (JY5321A_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.
JY5321A_API int | JY5321A_AI_ReadRawData_I16 (JY5321A_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.
JY5321A_API int | JY5321A_AI_ReadRawData_I32 (JY5321A_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.
JY5321A_API int | JY5321A_AI_ReadSinglePoint (JY5321A_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer.
JY5321A_API int | JY5321A_AI_ReadRawSinglePoint (JY5321A_DeviceHandle hDevice, int *readValue, int channelID)
Read raw single point for each channel to user defined data buffer.
JY5321A_API int | JY5321A_AI_Stop (JY5321A_DeviceHandle hDevice)
Stop AI acquisition.
JY5321A_API int | JY5321A_AI_SetSampleClock (JY5321A_DeviceHandle hDevice, JY5321A_SampleClockSource clockSource, JY5321A_ExternalSampleClockTerminal terminal, double expectedRate)
Set AI sampling clock. the source of the sampling clock defined by enum JY5321A_SampleClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.
JY5321A_API int | JY5321A_AI_SetStartTriggerType (JY5321A_DeviceHandle hDevice, JY5321A_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.
JY5321A_API int | JY5321A_AI_SetDigitalStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge, bool invertInput)
JY5321A_API int | JY5321A_AI_SetAnalogWindowStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerCondition is defined by enum JY5321A_AnalogWindowCondition.
JY5321A_API int | JY5321A_AI_SetAnalogHysteresisStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.
JY5321A_API int | JY5321A_AI_SetAnalogEdgeStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.
JY5321A_API int | JY5321A_AI_SetReferenceTriggerType (JY5321A_DeviceHandle hDevice, JY5321A_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.
JY5321A_API int | JY5321A_AI_SetDigitalReferenceTrigger (JY5321A_DeviceHandle hDevice, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge, bool invertInput)
Set AI digital reference trigger.the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_AI_SetAnalogWindowReferenceTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerCondition is defined by enum JY5321A_AnalogTriggerCondition.
JY5321A_API int | JY5321A_AI_SetAnalogHysteresisReferenceTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.
JY5321A_API int | JY5321A_AI_SetAnalogEdgeReferenceTrigger (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource triggerSource, JY5321A_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.
JY5321A_API int | JY5321A_AI_ResetAnalogTriggerConfig (JY5321A_DeviceHandle hDevice)
Reset AI Analog Trigger config.
JY5321A_API int | JY5321A_AI_SetAnalogTriggerMultiChannelMode (JY5321A_DeviceHandle hDevice, bool enableMultiChannelTriggerMode, JY5321A_MultiChannelCompositionLogic resultLogic)
Enable the trigger mode for multiple channels. If this mode is enabled, multiple channels participate in trigger comparison. If this mode is disabled, single channel participates in trigger comparison.
JY5321A_API int | JY5321A_AI_SetAnalogComparatorByEdge (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource *triggerSource, double *threshold, JY5321A_AnalogTriggerEdge *edges, unsigned int length, JY5321A_MultiChannelCompositionLogic resultLogic)
This function sets up the analog comparator on the device.
JY5321A_API int | JY5321A_AI_SetAnalogComparatorByWindow (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource *triggerSource, double *highThreshold, double *lowThreshold, JY5321A_AnalogWindowCondition *conditions, unsigned int length, JY5321A_MultiChannelCompositionLogic resultLogic)
This function sets up the analog comparator to trigger when the signal enters or exits a specified window.
JY5321A_API int | JY5321A_AI_SetAnalogComparatorByHysteresis (JY5321A_DeviceHandle hDevice, JY5321A_AnalogTriggerSource *triggerSource, double *highThreshold, double *lowThreshold, JY5321A_AnalogTriggerEdge *edges, unsigned int length, JY5321A_MultiChannelCompositionLogic resultLogic)
This function sets up the analog comparator to trigger when the signal enters or exits a specified window.
JY5321A_API int | JY5321A_AI_SetPreTriggerSamples (JY5321A_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY5321A_API int | JY5321A_AI_SetReTriggerCount (JY5321A_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count. The device will be triggered reTriggerCount times.
JY5321A_API int | JY5321A_AI_SendSoftTrigger (JY5321A_DeviceHandle hDevice, JY5321A_TriggerMode triggerMode)
Send the software trigger signal for AI.
JY5321A_API int | JY5321A_AI_WaitUntilDone (JY5321A_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode.
JY5321A_API int | JY5321A_AI_CheckBufferStatus (JY5321A_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI device buffer status.
JY5321A_API int | JY5321A_DI_AddLines (JY5321A_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DI channels.
JY5321A_API int | JY5321A_DI_ReadData (JY5321A_DeviceHandle hDevice, unsigned short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read DI data. The data type is short. There are independent 32 lines independently controlled, from 0 to 31.
JY5321A_API int | JY5321A_DI_ReadSinglePoint (JY5321A_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JY5321A_API int | JY5321A_DI_ReadSinglePoint_U16 (JY5321A_DeviceHandle hDevice, unsigned short *readValue)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JY5321A_API int | JY5321A_DI_SetSampleRate (JY5321A_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DI sampling rate. The sampling rate is the same for all channels.
JY5321A_API int | JY5321A_DI_SetSampleClock (JY5321A_DeviceHandle hDevice, JY5321A_SampleClockSource clockSource, JY5321A_ExternalSampleClockTerminal terminal, double expectedRate)
Set DI sampling clock source. the source of the sampling clock defined by enum JY5321A_SampleClockSource If the clock source is external, need to configure external clock terminal and external clock frequency..
JY5321A_API int | JY5321A_DI_Start (JY5321A_DeviceHandle hDevice)
Start DI acquisition.
JY5321A_API int | JY5321A_DI_Stop (JY5321A_DeviceHandle hDevice)
Stop DI acquisition.
JY5321A_API int | JY5321A_DI_SetMode (JY5321A_DeviceHandle hDevice, JY5321A_DI_SampleMode mode)
JY5321A_API int | JY5321A_DI_CheckBufferStatus (JY5321A_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status.
JY5321A_API int | JY5321A_DI_SetSamplesToAcquire (JY5321A_DeviceHandle hDevice, int samplesToAcquire)
Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.
JY5321A_API int | JY5321A_DI_SetStartTriggerType (JY5321A_DeviceHandle hDevice, JY5321A_DI_TriggerType triggerType)
Set DI start trigger type,the triggerType is defined by enum JY5321A_DI_TriggerType.
JY5321A_API int | JY5321A_DI_SetDigitalStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge)
Set DI digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_DI_SetReferenceTriggerType (JY5321A_DeviceHandle hDevice, JY5321A_DI_TriggerType triggerType)
Set DI reference trigger type,the triggerType is defined by enum JY5321A_DI_TriggerType.
JY5321A_API int | JY5321A_DI_SetDigitalReferenceTrigger (JY5321A_DeviceHandle hDevice, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_DI_SetPreTriggerSamples (JY5321A_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set DI pretrigger samples, the samples must greater than 0.
JY5321A_API int | JY5321A_DI_SendSoftTrigger (JY5321A_DeviceHandle hDevice, JY5321A_TriggerMode triggerMode)
Send the software trigger signal.
JY5321A_API int | JY5321A_DI_WaitUntilDone (JY5321A_DeviceHandle hDevice, bool *done)
Check if DI acquisition is completed in finite mode.
JY5321A_API int | JY5321A_DO_AddLines (JY5321A_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DO channels.
JY5321A_API int | JY5321A_DO_WriteData (JY5321A_DeviceHandle hDevice, unsigned short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
DO write data. The data type is short. There are independent 32 lines independently controlled, from 0 to 31.
JY5321A_API int | JY5321A_DO_WriteSinglePoint (JY5321A_DeviceHandle hDevice, bool *writeValues, int lineID)
Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5321A_DI_AddLines).
JY5321A_API int | JY5321A_DO_WriteSinglePoint_U16 (JY5321A_DeviceHandle hDevice, unsigned short writeValue)
Write DO single point.The data type is ushort. There are 16 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit represents one line.
JY5321A_API int | JY5321A_DO_SetUpdateRate (JY5321A_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DO update rate.The update rate is the same for all channels.
JY5321A_API int | JY5321A_DO_Start (JY5321A_DeviceHandle hDevice)
Start digital signal output.
JY5321A_API int | JY5321A_DO_Stop (JY5321A_DeviceHandle hDevice)
Stop digital signal output.
JY5321A_API int | JY5321A_DO_SetMode (JY5321A_DeviceHandle hDevice, JY5321A_DO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5321A_AO_UpdateMode.
JY5321A_API int | JY5321A_DO_SetSamplesToUpdate (JY5321A_DeviceHandle hDevice, int samplesToUpdate)
Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples.
JY5321A_API int | JY5321A_DO_SetSampleClock (JY5321A_DeviceHandle hDevice, JY5321A_SampleClockSource clockSource, JY5321A_ExternalSampleClockTerminal terminal, double expectedRate)
Set DO sampling clock source. the source of the sampling clock defined by enum JY5321A_SampleClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.
JY5321A_API int | JY5321A_DO_CheckBufferStatus (JY5321A_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DO device buffer status.
JY5321A_API int | JY5321A_DO_WaitUntilDone (JY5321A_DeviceHandle hDevice, bool *done, int timeOut)
Check finite digital signal output is complete.
JY5321A_API int | JY5321A_DO_SetStartTriggerType (JY5321A_DeviceHandle hDevice, JY5321A_DO_TriggerType triggerType)
Set DO start trigger type,the triggerType is defined by enum JY5321A_DO_TriggerType.
JY5321A_API int | JY5321A_DO_SetDigitalStartTrigger (JY5321A_DeviceHandle hDevice, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge)
Set DO digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_DO_SendSoftTrigger (JY5321A_DeviceHandle hDevice)
Send the software trigger signal.
JY5321A_API int | JY5321A_DO_SetOutputCompleteState (JY5321A_DeviceHandle hDevice, JY5321A_OutputCompleteState State)
Set DO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.
JY5321A_API int | JY5321A_DisableAICalibration (JY5321A_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false.
JY5321A_API int | JY5321A_CI_EnableChannel (JY5321A_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 2 counter.
JY5321A_API int | JY5321A_CI_SetCounterType (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_MeasureType measureType)
Set CI measure type.
JY5321A_API int | JY5321A_CI_SetSignalReverse (JY5321A_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JY5321A_API int | JY5321A_CI_SetCounterParament (JY5321A_DeviceHandle hDevice, unsigned int channel, int initCount, JY5321A_CountDirection countDirection)
Set CI count parameter.
JY5321A_API int | JY5321A_CI_SetZReloadEnabled (JY5321A_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JY5321A_API int | JY5321A_CI_SetStartingEdge (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_StartingEdge startingEdge)
Set starting edge.
JY5321A_API int | JY5321A_CI_SetFirstSampleClock (JY5321A_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set the first sample clock data ignore or not.
JY5321A_API int | JY5321A_CI_SetMode (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5321A_CI_SampleMode.
JY5321A_API int | JY5321A_CI_SetSampleClock (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_SampleClock clock, JY5321A_ExternalSampleClockTerminal terminal, double rate)
Set counter input sampling clock source. If the clockType is internal, user need to define sampleRate, if the clockType is JY5321A_CI_ImplicitClk, the sample rate determine by the measuer signal.
JY5321A_API int | JY5321A_CI_SetTimeBase (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CountTimeBase timebaseSrc, JY5321A_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter input time base,the time base defined by enum JY5321A_CountTimeBase.
JY5321A_API int | JY5321A_CI_SetSamplesToAcquire (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M.
JY5321A_API int | JY5321A_CI_SetEdgeCountEvent (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_CounterEventSignalIdleState idleState, unsigned int threshold, bool reset)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY5321A_API int | JY5321A_CI_SetPauseTriggerLevel (JY5321A_DeviceHandle hDevice, unsigned int channel, bool enable, JY5321A_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JY5321A_API int | JY5321A_CI_SetPauseTriggerTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal pauseTriggerTerminal)
Set CI pause trigger terminal.
JY5321A_API int | JY5321A_CI_ReadSingleCountValue (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5321A_CI_EdgeCount、JY5321A_CI_EncoderX1、 JY5321A_CI_EncoderX2 、 JY5321A_CI_EncoderX4 、JY5321A_CI_EncoderTwoPulse.
JY5321A_API int | JY5321A_CI_ReadSingleMeasureValue (JY5321A_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows. for JY5321A_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5321A_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5321A_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5321A_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.
JY5321A_API int | JY5321A_CI_ReadCountValues (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5321A_CI_EdgeCount、JY5321A_CI_EncoderX1、 JY5321A_CI_EncoderX2 、 JY5321A_CI_EncoderX4 、JY5321A_CI_EncoderTwoPulse.
JY5321A_API int | JY5321A_CI_ReadMeasureValues (JY5321A_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5321A_CI_Measure_EdgeSeparation JY5321A_CI_Measure_Pulse JY5321A_CI_Measure_Frequency JY5321A_CI_Measure_Period JY5321A_CI_Measure_SemiPeriod for JY5321A_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s. for JY5321A_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5321A_CI_Measure_SemiPeriod type, the measureValues1 is signal period, the unit is s,the measureValues2 invalid. for JY5321A_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5321A_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5321A_CI_Measure_Period type and JY5321A_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.
JY5321A_API int | JY5321A_CI_Start (JY5321A_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JY5321A_API int | JY5321A_CI_Stop (JY5321A_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JY5321A_API int | JY5321A_CI_SetValueReturnMode (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CI_ValueReturnMode mode)
Config CI return value mode, only for JY5321A_CI_Measure_EdgeSeparation type.
JY5321A_API int | JY5321A_CI_CheckBufferStatus (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status.
JY5321A_API int | JY5321A_CI_SendSoftTrigger (JY5321A_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JY5321A_API int | JY5321A_CI_SetStartTriggerType (JY5321A_DeviceHandle hDevice, int channel, JY5321A_CIO_TriggerType triggerType)
Set CI start trigger type,the triggerType is defined by enum JY5321A_CI_TriggerType.
JY5321A_API int | JY5321A_CI_SetDigitalStartTrigger (JY5321A_DeviceHandle hDevice, int channel, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_CI_SetSourceTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal sourceTerminal)
Set source terminal.
JY5321A_API int | JY5321A_CI_SetGateTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal gateTerminal)
JY5321A_API int | JY5321A_CI_SetAuxTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal auxTerminal)
JY5321A_API int | JY5321A_CI_SetOutTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_Signal_Destination outTerminal)
JY5321A_API int | JY5321A_CO_EnableChannel (JY5321A_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel.
JY5321A_API int | JY5321A_CO_SetCounterParament (JY5321A_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5321A_CO_IdleState IdleState, double delay)
Set CO parameter.
JY5321A_API int | JY5321A_CO_SetFrequency (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
JY5321A_API int | JY5321A_CO_SetFrequencyOnFly (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set the output pulse frequency of the counter in real time. After the output starts, you can call this interface to modify the pulse frequency in real time.
JY5321A_API int | JY5321A_CO_WriteData (JY5321A_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.
JY5321A_API int | JY5321A_CO_CheckBufferStatus (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status.
JY5321A_API int | JY5321A_CO_CheckCounterStatus (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter output status.
JY5321A_API int | JY5321A_CO_WaitUntilDone (JY5321A_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status.
JY5321A_API int | JY5321A_CO_SetSamplesToUpdate (JY5321A_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.
JY5321A_API int | JY5321A_CO_Start (JY5321A_DeviceHandle hDevice, unsigned int channel)
Start counter output.
JY5321A_API int | JY5321A_CO_Stop (JY5321A_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
JY5321A_API int | JY5321A_CO_SendSoftTrigger (JY5321A_DeviceHandle hDevice, int channel)
Send the software trigger signal.
JY5321A_API int | JY5321A_CO_SetMode (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CO_OUTMode mode)
Set counter output mode, the mode defined by enum JY5321A_CO_UpdateMode.
JY5321A_API int | JY5321A_CO_SetStartTriggerType (JY5321A_DeviceHandle hDevice, int channel, JY5321A_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.
JY5321A_API int | JY5321A_CO_SetDigitalStartTrigger (JY5321A_DeviceHandle hDevice, int channel, JY5321A_DigitalTriggerSource triggerSource, JY5321A_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.
JY5321A_API int | JY5321A_CO_SetTimeBase (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CountTimeBase timebaseSrc, JY5321A_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter output time base,the time base defined by enum JY5321A_CountTimeBase.
JY5321A_API int | JY5321A_CO_SetSourceTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal sourceTerminal)
Set CO source terminal.
JY5321A_API int | JY5321A_CO_SetGateTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal gateTerminal)
Set CO gate terminal.
JY5321A_API int | JY5321A_CO_SetPauseTriggerLevel (JY5321A_DeviceHandle hDevice, unsigned int channel, bool enable, JY5321A_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JY5321A_API int | JY5321A_CO_SetPauseTriggerTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_InputTerminal pauseTriggerTerminal)
Set CO Pause Trigger terminal.
JY5321A_API int | JY5321A_CO_SetOutTerminal (JY5321A_DeviceHandle hDevice, int channel, JY5321A_Signal_Destination outTerminal)
JY5321A_API int | JY5321A_CO_SetPauseTriggerOutState (JY5321A_DeviceHandle hDevice, unsigned int channel, JY5321A_CO_PauseTrigger_OutState outState)
Config CO out state when pause trigger valid.
JY5321A_API int | JY5321A_SetPFIFilter (JY5321A_DeviceHandle hDevice, int line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI.
JY5321A_API int | JY5321A_AI_GetSamplingInfo (JY5321A_DeviceHandle hDevice, double *convertClockRate, int *oversamplingRatio, double *groupDelay)
Set groupDelay.
JY5321A_API int | JY5321A_AI_SetRawDataWidth (JY5321A_DeviceHandle hDevice, JY5321A_AI_RawDataWidth rawDataWidth)
Set Raw Data Width.
JY5321A_API int | JY5321A_AI_GetRawDataWidth (JY5321A_DeviceHandle hDevice, JY5321A_AI_RawDataWidth *rawDataWidth)
Get Raw Data Width.
JY5321A_API int | JY5321A_AI_GetScalingCoefficients (JY5321A_DeviceHandle hDevice, ScalingCoefficients coefOfEnabledChannels[], int enabledChannelCount)
Get Scaling Coefficients.

Typedef Documentation

◆ JY5321A_DeviceHandle

typedef void* JY5321A_DeviceHandle

Windows Linux

Enumeration Type Documentation

◆ JY5321A_AI_BandWidth

enum JY5321A_AI_BandWidth
Enumerator
JY5321A_AI_BandWidth_25K | AI BandWidth is 50KHz.
JY5321A_AI_BandWidth_220K | AI BandWidth is 220KHz.

◆ JY5321A_AI_RawDataWidth

enum JY5321A_AI_RawDataWidth
Enumerator
JY5321A_AI_RawDataWidth_Auto | Auto.
JY5321A_AI_RawDataWidth_16bits | 16bits
JY5321A_AI_RawDataWidth_32bits | 32bits

◆ JY5321A_AI_SampleMode

enum JY5321A_AI_SampleMode
Enumerator
JY5321A_AI_Finite | AI Finite mode.
JY5321A_AI_Continuous | AI Continuous mode.
JY5321A_AI_Single | AI Single Mode.

◆ JY5321A_AI_TriggerType

enum JY5321A_AI_TriggerType
Enumerator
JY5321A_AI_Immediately | AI Immediately trigger.
JY5321A_AI_Digital | AI Digital trigger.
JY5321A_AI_Analog | AI Analog trigger.
JY5321A_AI_Soft | AI Soft trigger.

◆ JY5321A_AnalogTriggerEdge

enum JY5321A_AnalogTriggerEdge
Enumerator
JY5321A_RisingSlope | Rsing edge for Analog trigger.
JY5321A_FallingSlope | Falling edge for Analog trigger.

◆ JY5321A_AnalogTriggerSource

enum JY5321A_AnalogTriggerSource
Enumerator
JY5321A_Channel_0 | AI Channel 0 as analog trigger source.
JY5321A_Channel_1 | AI Channel 1 as analog trigger source.
JY5321A_Channel_2 | AI Channel 2 as analog trigger source.
JY5321A_Channel_3 | AI Channel 3 as analog trigger source.
JY5321A_Channel_4 | AI Channel 4 as analog trigger source.
JY5321A_Channel_5 | AI Channel 5 as analog trigger source.
JY5321A_Channel_6 | AI Channel 6 as analog trigger source.
JY5321A_Channel_7 | AI Channel 7 as analog trigger source.
JY5321A_Channel_8 | AI Channel 8 as analog trigger source.
JY5321A_Channel_9 | AI Channel 9 as analog trigger source.
JY5321A_Channel_10 | AI Channel 10 as analog trigger source.
JY5321A_Channel_11 | AI Channel 11 as analog trigger source.
JY5321A_Channel_12 | AI Channel 12 as analog trigger source.
JY5321A_Channel_13 | AI Channel 13 as analog trigger source.
JY5321A_Channel_14 | AI Channel 14 as analog trigger source.
JY5321A_Channel_15 | AI Channel 15 as analog trigger source.
JY5321A_Channel_16 | AI Channel 16 as analog trigger source.
JY5321A_Channel_17 | AI Channel 17 as analog trigger source.
JY5321A_Channel_18 | AI Channel 18 as analog trigger source.
JY5321A_Channel_19 | AI Channel 19 as analog trigger source.
JY5321A_Channel_20 | AI Channel 20 as analog trigger source.
JY5321A_Channel_21 | AI Channel 21 as analog trigger source.
JY5321A_Channel_22 | AI Channel 22 as analog trigger source.
JY5321A_Channel_23 | AI Channel 23 as analog trigger source.
JY5321A_Channel_24 | AI Channel 24 as analog trigger source.
JY5321A_Channel_25 | AI Channel 25 as analog trigger source.
JY5321A_Channel_26 | AI Channel 26 as analog trigger source.
JY5321A_Channel_27 | AI Channel 27 as analog trigger source.
JY5321A_Channel_28 | AI Channel 28 as analog trigger source.
JY5321A_Channel_29 | AI Channel 29 as analog trigger source.
JY5321A_Channel_30 | AI Channel 30 as analog trigger source.
JY5321A_Channel_31 | AI Channel 31 as analog trigger source.

◆ JY5321A_AnalogWindowCondition

enum JY5321A_AnalogWindowCondition
Enumerator
JY5321A_Entering | Analog Window trigger condition is Entering.
JY5321A_Leaving | Analog Window trigger condition is Leaving.

◆ JY5321A_CI_CounterEventSignalIdleState

enum JY5321A_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JY5321A_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JY5321A_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JY5321A_CI_MeasureType

enum JY5321A_CI_MeasureType
Enumerator
JY5321A_CI_EdgeCount | Edge count.
JY5321A_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JY5321A_CI_Measure_PulseWidth | Pulse Measurement.
JY5321A_CI_Measure_SemiPeriod | SemiPeriod Measurement.
JY5321A_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JY5321A_CI_EncoderX1 | Quadrature Encoded X1.
JY5321A_CI_EncoderX2 | Quadrature Encoded X2.
JY5321A_CI_EncoderX4 | Quadrature Encoded X4.
JY5321A_CI_EncoderTwoPulse | Two Pulse Encoder.

◆ JY5321A_CI_SampleClock

enum JY5321A_CI_SampleClock
Enumerator
JY5321A_CI_ImplicitClock | CI Implicit Clock.
JY5321A_CI_InternalClock | CI Internal Clock.
JY5321A_CI_ExternalClock | CI External Clock.

◆ JY5321A_CI_SampleMode

enum JY5321A_CI_SampleMode
Enumerator
JY5321A_CI_Finite | CI Finite mode.
JY5321A_CI_Continuous | CI Continuous mode.
JY5321A_CI_Single | CI Single mode.

◆ JY5321A_CI_StartingEdge

enum JY5321A_CI_StartingEdge
Enumerator
JY5321A_RisingEdge | Rising edge as the start edge.
JY5321A_FallingEdge | Falling edge as the start edge.
JY5321A_AnyEdge | any edge edge as the start edge.

◆ JY5321A_CI_ValueReturnMode

enum JY5321A_CI_ValueReturnMode
Enumerator
JY5321A_CI_ReturnTwoValue |
JY5321A_CI_ReturnOneValue | High Level as the CI Counter Event Signal Idle State.

◆ JY5321A_CIO_TriggerType

enum JY5321A_CIO_TriggerType
Enumerator
JY5321A_CIO_Immediately | CI Immediately trigger.
JY5321A_CIO_Soft | CI Soft trigger.
JY5321A_CIO_Digital | CI Digital trigger.

◆ JY5321A_CO_IdleState

enum JY5321A_CO_IdleState
Enumerator
JY5321A_CO_LowLevel | Low Level as the co idle state.
JY5321A_CO_HighLevel | High Level as the co idle state.

◆ JY5321A_CO_OUTMode

enum JY5321A_CO_OUTMode
Enumerator
JY5321A_CO_Finite | CO Finite mode.
JY5321A_CO_ContinuousWrapping | CO ContinuousWrapping mode.
JY5321A_CO_ContinuousNoWrapping | CO ContinuousNoWrapping mode.
JY5321A_CO_Single | CO Finite mode.

◆ JY5321A_CO_PauseTrigger_OutState

enum JY5321A_CO_PauseTrigger_OutState
Enumerator
JY5321A_CO_HoldOn | CO hold on current state.
JY5321A_CO_HighOut | CO out high level.
JY5321A_CO_LowOut | CO out low level.

◆ JY5321A_CountDirection

enum JY5321A_CountDirection
Enumerator
JY5321A_CI_Count_Up | Increases count.
JY5321A_CI_Count_Down | Reduction count.
JY5321A_CI_Count_External | External terminal determines the count direction.

◆ JY5321A_CountTimeBase

enum JY5321A_CountTimeBase
Enumerator
JY5321A_Internal_Timebase_100M | 100MHz Internal TimeBase
JY5321A_Internal_Timebase_5M | 5MHz Internal TimeBase
JY5321A_Internal_Timebase_100K | 100KHz Internal TimeBase
JY5321A_External_Timebase | External TimeBase.

◆ JY5321A_DI_SampleMode

enum JY5321A_DI_SampleMode
Enumerator
JY5321A_DI_Finite
JY5321A_DI_Continuous
JY5321A_DI_Single

◆ JY5321A_DI_TriggerType

enum JY5321A_DI_TriggerType
Enumerator
JY5321A_DI_Immediately
JY5321A_DI_Digital
JY5321A_DI_Soft

◆ JY5321A_DigitalTriggerEdge

enum JY5321A_DigitalTriggerEdge
Enumerator
JY5321A_Rising | Rsing edge for digital trigger.
JY5321A_Falling | Falling edge for digital trigger.

◆ JY5321A_DigitalTriggerSource

enum JY5321A_DigitalTriggerSource
Enumerator
JY5321A_PFI0 | PFI_0 as the digital trigger source.
JY5321A_PFI1 | PFI_1 as the digital trigger source.
JY5321A_PFI2 | PFI_2 as the digital trigger source.
JY5321A_PFI3 | PFI_3 as the digital trigger source.
JY5321A_PFI4 | PFI_4 as the digital trigger source.
JY5321A_PFI5 | PFI_5 as the digital trigger source.
JY5321A_PFI6 | PFI_6 as the digital trigger source.
JY5321A_PFI7 | PFI_7 as the digital trigger source.
JY5321A_PFI8 | PFI_8 as the digital trigger source.
JY5321A_PFI9 | PFI_9 as the digital trigger source.
JY5321A_PFI10 | PFI_10 as the digital trigger source.
JY5321A_PFI11 | PFI_11 as the digital trigger source.
JY5321A_PFI12 | PFI_12 as the digital trigger source.
JY5321A_PFI13 | PFI_13 as the digital trigger source.
JY5321A_PFI14 | PFI_14 as the digital trigger source.
JY5321A_PFI15 | PFI_15 as the digital trigger source.
JY5321A_PFI16 | PFI_16 as the digital trigger source.
JY5321A_PFI17 | PFI_17 as the digital trigger source.
JY5321A_PFI18 | PFI_18 as the digital trigger source.
JY5321A_PFI19 | PFI_19 as the digital trigger source.
JY5321A_PFI20 | PFI_20 as the digital trigger source.
JY5321A_PFI21 | PFI_21 as the digital trigger source.
JY5321A_PFI22 | PFI_22 as the digital trigger source.
JY5321A_PFI23 | PFI_23 as the digital trigger source.
JY5321A_PFI24 | PFI_24 as the digital trigger source.
JY5321A_PFI25 | PFI_25 as the digital trigger source.
JY5321A_PFI26 | PFI_26 as the digital trigger source.
JY5321A_PFI27 | PFI_27 as the digital trigger source.
JY5321A_PFI28 | PFI_28 as the digital trigger source.
JY5321A_PFI29 | PFI_29 as the digital trigger source.
JY5321A_PFI30 | PFI_30 as the digital trigger source.
JY5321A_PFI31 | PFI_31 as the digital trigger source.
JY5321A_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5321A_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5321A_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5321A_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5321A_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5321A_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5321A_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5321A_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY5321A_Inter_AI_StartTrig | AI_StartTrig as the digital trigger source.
JY5321A_Inter_AI_ReferenceTrig | AI_ReferenceTrig as the digital trigger source.
JY5321A_Inter_CIO_0_StartTrig | CIO 0 StartTrig as the digital trigger source.
JY5321A_Inter_CIO_1_StartTrig | CIO 1 StartTrig as the digital trigger source.
JY5321A_Inter_Counter_0_Output | CO_0_Output as the digital trigger source.
JY5321A_Inter_Counter_1_Output | CO_1_Output as the digital trigger source.
JY5321A_Inter_DI_StartTrig | DI_StartTrig as the digital trigger source.
JY5321A_Inter_DI_ReferenceTrig | DI_ReferenceTrig as the digital trigger source.
JY5321A_Inter_DO_StartTrig | DO_StartTrig as the digital trigger source.

◆ JY5321A_DO_TriggerType

enum JY5321A_DO_TriggerType
Enumerator
JY5321A_DO_Immediately
JY5321A_DO_Digital
JY5321A_DO_Soft

◆ JY5321A_DO_UpdateMode

enum JY5321A_DO_UpdateMode
Enumerator
JY5321A_DO_Finite
JY5321A_DO_ContinuousWrapping
JY5321A_DO_ContinuousNoWrapping
JY5321A_DO_Single

◆ JY5321A_ExternalReferenceClockTerminal

enum JY5321A_ExternalReferenceClockTerminal
Enumerator
JY5321A_RefClock_PFI_0 | PFI0 as External Clock Source.
JY5321A_RefClock_PFI_1 | PFI1 as External Clock Source.
JY5321A_RefClock_PFI_2 | PFI2 as External Clock Source.
JY5321A_RefClock_PFI_3 | PFI3 as External Clock Source.
JY5321A_RefClock_PFI_4 | PFI4 as External Clock Source.
JY5321A_RefClock_PFI_5 | PFI5 as External Clock Source.
JY5321A_RefClock_PFI_6 | PFI6 as External Clock Source.
JY5321A_RefClock_PFI_7 | PFI7 as External Clock Source.
JY5321A_RefClock_PFI_8 | PFI8 as External Clock Source.
JY5321A_RefClock_PFI_9 | PFI9 as External Clock Source.
JY5321A_RefClock_PFI_10 | PFI10 as External Clock Source.
JY5321A_RefClock_PFI_11 | PFI11 as External Clock Source.
JY5321A_RefClock_PFI_12 | PFI12 as External Clock Source.
JY5321A_RefClock_PFI_13 | PFI13 as External Clock Source.
JY5321A_RefClock_PFI_14 | PFI14 as External Clock Source.
JY5321A_RefClock_PFI_15 | PFI15 as External Clock Source.
JY5321A_RefClock_PFI_16 | PFI16 as External Clock Source.
JY5321A_RefClock_PFI_17 | PFI17 as External Clock Source.
JY5321A_RefClock_PFI_18 | PFI18 as External Clock Source.
JY5321A_RefClock_PFI_19 | PFI19 as External Clock Source.
JY5321A_RefClock_PFI_20 | PFI20 as External Clock Source.
JY5321A_RefClock_PFI_21 | PFI21 as External Clock Source.
JY5321A_RefClock_PFI_22 | PFI22 as External Clock Source.
JY5321A_RefClock_PFI_23 | PFI23 as External Clock Source.
JY5321A_RefClock_PFI_24 | PFI24 as External Clock Source.
JY5321A_RefClock_PFI_25 | PFI25 as External Clock Source.
JY5321A_RefClock_PFI_26 | PFI26 as External Clock Source.
JY5321A_RefClock_PFI_27 | PFI27 as External Clock Source.
JY5321A_RefClock_PFI_28 | PFI28 as External Clock Source.
JY5321A_RefClock_PFI_29 | PFI29 as External Clock Source.
JY5321A_RefClock_PFI_30 | PFI30 as External Clock Source.
JY5321A_RefClock_PFI_31 | PFI31 as External Clock Source.
JY5321A_PXIe_Clk100 | The PXIe chassis 100MHz as JY5321A_ReferenceClock, only for PXIe module.

◆ JY5321A_ExternalSampleClockTerminal

enum JY5321A_ExternalSampleClockTerminal
Enumerator
JY5321A_SampleClock_PFI_0 | PFI0 as External Clock Source.
JY5321A_SampleClock_PFI_1 | PFI1 as External Clock Source.
JY5321A_SampleClock_PFI_2 | PFI2 as External Clock Source.
JY5321A_SampleClock_PFI_3 | PFI3 as External Clock Source.
JY5321A_SampleClock_PFI_4 | PFI4 as External Clock Source.
JY5321A_SampleClock_PFI_5 | PFI5 as External Clock Source.
JY5321A_SampleClock_PFI_6 | PFI6 as External Clock Source.
JY5321A_SampleClock_PFI_7 | PFI7 as External Clock Source.
JY5321A_SampleClock_PFI_8 | PFI8 as External Clock Source.
JY5321A_SampleClock_PFI_9 | PFI9 as External Clock Source.
JY5321A_SampleClock_PFI_10 | PFI10 as External Clock Source.
JY5321A_SampleClock_PFI_11 | PFI11 as External Clock Source.
JY5321A_SampleClock_PFI_12 | PFI12 as External Clock Source.
JY5321A_SampleClock_PFI_13 | PFI13 as External Clock Source.
JY5321A_SampleClock_PFI_14 | PFI14 as External Clock Source.
JY5321A_SampleClock_PFI_15 | PFI15 as External Clock Source.
JY5321A_SampleClock_PFI_16 | PFI16 as External Clock Source.
JY5321A_SampleClock_PFI_17 | PFI17 as External Clock Source.
JY5321A_SampleClock_PFI_18 | PFI18 as External Clock Source.
JY5321A_SampleClock_PFI_19 | PFI19 as External Clock Source.
JY5321A_SampleClock_PFI_20 | PFI20 as External Clock Source.
JY5321A_SampleClock_PFI_21 | PFI21 as External Clock Source.
JY5321A_SampleClock_PFI_22 | PFI22 as External Clock Source.
JY5321A_SampleClock_PFI_23 | PFI23 as External Clock Source.
JY5321A_SampleClock_PFI_24 | PFI24 as External Clock Source.
JY5321A_SampleClock_PFI_25 | PFI25 as External Clock Source.
JY5321A_SampleClock_PFI_26 | PFI26 as External Clock Source.
JY5321A_SampleClock_PFI_27 | PFI27 as External Clock Source.
JY5321A_SampleClock_PFI_28 | PFI28 as External Clock Source.
JY5321A_SampleClock_PFI_29 | PFI29 as External Clock Source.
JY5321A_SampleClock_PFI_30 | PFI30 as External Clock Source.
JY5321A_SampleClock_PFI_31 | PFI31 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_0 | PXI_Trig0 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_1 | PXI_Trig1 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_2 | PXI_Trig2 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_3 | PXI_Trig3 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_4 | PXI_Trig4 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_5 | PXI_Trig5 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_6 | PXI_Trig6 as External Clock Source.
JY5321A_SampleClock_PXI_Trig_7 | PXI_Trig7 as External Clock Source.
JY5321A_Inter_AI_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5321A_Inter_CI_0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY5321A_Inter_CI_1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY5321A_Inter_CO_0_Output | CO_0_Output as other task External Clock Source.
JY5321A_Inter_CO_1_Output | CO_1_Output as other task External Clock Source.
JY5321A_Clock_DI_SampleClock | DI_SampleClock as other task External Clock Source.
JY5321A_Clock_DO_SampleClock | DO_SampleClock as other task External Clock Source.

◆ JY5321A_InputTerminal

enum JY5321A_InputTerminal
Enumerator
JY5321A_IN_PFI0 | PFI_0 as Input Terminal.
JY5321A_IN_PFI1 | PFI_1 as Input Terminal.
JY5321A_IN_PFI2 | PFI_2 as Input Terminal.
JY5321A_IN_PFI3 | PFI_3 as Input Terminal.
JY5321A_IN_PFI4 | PFI_4 as Input Terminal.
JY5321A_IN_PFI5 | PFI_5 as Input Terminal.
JY5321A_IN_PFI6 | PFI_6 as Input Terminal.
JY5321A_IN_PFI7 | PFI_7 as Input Terminal.
JY5321A_IN_PFI8 | PFI_8 as Input Terminal.
JY5321A_IN_PFI9 | PFI_9 as Input Terminal.
JY5321A_IN_PFI10 | PFI_10 as the Input Terminal.
JY5321A_IN_PFI11 | PFI_11 as the Input Terminal.
JY5321A_IN_PFI12 | PFI_12 as the Input Terminal.
JY5321A_IN_PFI13 | PFI_13 as the Input Terminal.
JY5321A_IN_PFI14 | PFI_14 as the Input Terminal.
JY5321A_IN_PFI15 | PFI_15 as the Input Terminal.
JY5321A_IN_PFI16 | PFI_16 as the Input Terminal.
JY5321A_IN_PFI17 | PFI_17 as the Input Terminal.
JY5321A_IN_PFI18 | PFI_18 as the Input Terminal.
JY5321A_IN_PFI19 | PFI_19 as the Input Terminal.
JY5321A_IN_PFI20 | PFI_20 as the Input Terminal.
JY5321A_IN_PFI21 | PFI_21 as the Input Terminal.
JY5321A_IN_PFI22 | PFI_22 as the Input Terminal.
JY5321A_IN_PFI23 | PFI_23 as the Input Terminal.
JY5321A_IN_PFI24 | PFI_24 as the Input Terminal.
JY5321A_IN_PFI25 | PFI_25 as the Input Terminal.
JY5321A_IN_PFI26 | PFI_26 as the Input Terminal.
JY5321A_IN_PFI27 | PFI_27 as the Input Terminal.
JY5321A_IN_PFI28 | PFI_28 as the Input Terminal.
JY5321A_IN_PFI29 | PFI_29 as the Input Terminal.
JY5321A_IN_PFI30 | PFI_30 as the Input Terminal.
JY5321A_IN_PFI31 | PFI_31 as the Input Terminal.
JY5321A_IN_PXI_Trig0 | PXI_Trig0 as Input Terminal.
JY5321A_IN_PXI_Trig1 | PXI_Trig1 as Input Terminal.
JY5321A_IN_PXI_Trig2 | PXI_Trig2 as Input Terminal.
JY5321A_IN_PXI_Trig3 | PXI_Trig3 as Input Terminal.
JY5321A_IN_PXI_Trig4 | PXI_Trig4 as Input Terminal.
JY5321A_IN_PXI_Trig5 | PXI_Trig5 as Input Terminal.
JY5321A_IN_PXI_Trig6 | PXI_Trig6 as Input Terminal.
JY5321A_IN_PXI_Trig7 | PXI_Trig7 as Input Terminal.
JY5321A_IN_AI_SampleClock | AI_SampleClock as the Input Terminal.
JY5321A_IN_CO_0_Output | CO_0_Output as Input Terminal.
JY5321A_IN_CO_1_Output | CO_1_Output as Input Terminal.
JY5321A_IN_CIO_100MHz | Counter 100MHz timebase as Input Terminal.
JY5321A_IN_CIO_5MHz | Counter 5MHz timebase as Input Terminal.
JY5321A_IN_CIO_100kHz | Counter 100kHz timebase as Input Terminal.
JY5321A_IN_DI_SampleClock |
JY5321A_IN_DO_SampleClock |

◆ JY5321A_LevelState

enum JY5321A_LevelState
Enumerator
JY5321A_LowLevel | Low Level as the pause trigger active level.
JY5321A_HighLevel | High Level as the pause trigger active level.

◆ JY5321A_MultiChannelCompositionLogic

enum JY5321A_MultiChannelCompositionLogic
Enumerator
JY5321A_Or | Multichannel result take or.
JY5321A_And | Multichannel results take and.

◆ JY5321A_OutputCompleteState

enum JY5321A_OutputCompleteState
Enumerator
JY5321A_Zero
JY5321A_Hold

◆ JY5321A_OutputType

enum JY5321A_OutputType
Enumerator
JY5321A_Logic
JY5321A_OCGate

◆ JY5321A_ReferenceClockSource

enum JY5321A_ReferenceClockSource
Enumerator
JY5321A_InternalRefClock | The onboard 25 MHz as JY5321A_ReferenceClock.
JY5321A_ExternalRefClock | External Clock Source.

◆ JY5321A_SampleClockSource

enum JY5321A_SampleClockSource
Enumerator
JY5321A_InternalSampleClock | Internal Clock Source.
JY5321A_ExternalSampleClock | External Clock Source.

◆ JY5321A_Signal_Destination

enum JY5321A_Signal_Destination
Enumerator
JY5321A_PFI0_OUT | PFI0 as the signal desition to rout.
JY5321A_PFI1_OUT | PFI1 as the signal desition to rout.
JY5321A_PFI2_OUT | PFI2 as the signal desition to rout.
JY5321A_PFI3_OUT | PFI3 as the signal desition to rout.
JY5321A_PFI4_OUT | PFI4 as the signal desition to rout.
JY5321A_PFI5_OUT | PFI5 as the signal desition to rout.
JY5321A_PFI6_OUT | PFI6 as the signal desition to rout.
JY5321A_PFI7_OUT | PFI7 as the signal desition to rout.
JY5321A_PFI8_OUT | PFI8 as the signal desition to rout.
JY5321A_PFI9_OUT | PFI9 as the signal desition to rout.
JY5321A_PFI10_OUT | PFI10 as the signal desition to rout.
JY5321A_PFI11_OUT | PFI11 as the signal desition to rout.
JY5321A_PFI12_OUT | PFI12 as the signal desition to rout.
JY5321A_PFI13_OUT | PFI13 as the signal desition to rout.
JY5321A_PFI14_OUT | PFI14 as the signal desition to rout.
JY5321A_PFI15_OUT | PFI15 as the signal desition to rout.
JY5321A_PFI16_OUT | PFI16 as the signal desition to rout.
JY5321A_PFI17_OUT | PFI17 as the signal desition to rout.
JY5321A_PFI18_OUT | PFI18 as the signal desition to rout.
JY5321A_PFI19_OUT | PFI19 as the signal desition to rout.
JY5321A_PFI20_OUT | PFI20 as the signal desition to rout.
JY5321A_PFI21_OUT | PFI21 as the signal desition to rout.
JY5321A_PFI22_OUT | PFI22 as the signal desition to rout.
JY5321A_PFI23_OUT | PFI23 as the signal desition to rout.
JY5321A_PFI24_OUT | PFI24 as the signal desition to rout.
JY5321A_PFI25_OUT | PFI25 as the signal desition to rout.
JY5321A_PFI26_OUT | PFI26 as the signal desition to rout.
JY5321A_PFI27_OUT | PFI27 as the signal desition to rout.
JY5321A_PFI28_OUT | PFI28 as the signal desition to rout.
JY5321A_PFI29_OUT | PFI29 as the signal desition to rout.
JY5321A_PFI30_OUT | PFI30 as the signal desition to rout.
JY5321A_PFI31_OUT | PFI31 as the signal desition to rout.
JY5321A_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JY5321A_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JY5321A_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JY5321A_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JY5321A_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JY5321A_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JY5321A_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JY5321A_PXITrig7_OUT | PXITrig7 as the signal desition to rout.
JY5321A_None | None desition to rout.

◆ JY5321A_Signal_Source

enum JY5321A_Signal_Source
Enumerator
JY5321A_Signal_PFI_0 | PFI0 as the source signal to rout.
JY5321A_Signal_PFI_1 | PFI1 as the source signal to rout.
JY5321A_Signal_PFI_2 | PFI2 as the source signal to rout.
JY5321A_Signal_PFI_3 | PFI3 as the source signal to rout.
JY5321A_Signal_PFI_4 | PFI4 as the source signal to rout.
JY5321A_Signal_PFI_5 | PFI5 as the source signal to rout.
JY5321A_Signal_PFI_6 | PFI6 as the source signal to rout.
JY5321A_Signal_PFI_7 | PFI7 as the source signal to rout.
JY5321A_Signal_PFI_8 | PFI8 as the source signal to rout.
JY5321A_Signal_PFI_9 | PFI9 as the source signal to rout.
JY5321A_Signal_PFI_10 | PFI10 as the source signal to rout.
JY5321A_Signal_PFI_11 | PFI11 as the source signal to rout.
JY5321A_Signal_PFI_12 | PFI12 as the source signal to rout.
JY5321A_Signal_PFI_13 | PFI13 as the source signal to rout.
JY5321A_Signal_PFI_14 | PFI14 as the source signal to rout.
JY5321A_Signal_PFI_15 | PFI15 as the source signal to rout.
JY5321A_Signal_PFI_16 | PFI16 as the source signal to rout.
JY5321A_Signal_PFI_17 | PFI17 as the source signal to rout.
JY5321A_Signal_PFI_18 | PFI18 as the source signal to rout.
JY5321A_Signal_PFI_19 | PFI19 as the source signal to rout.
JY5321A_Signal_PFI_20 | PFI20 as the source signal to rout.
JY5321A_Signal_PFI_21 | PFI21 as the source signal to rout.
JY5321A_Signal_PFI_22 | PFI22 as the source signal to rout.
JY5321A_Signal_PFI_23 | PFI23 as the source signal to rout.
JY5321A_Signal_PFI_24 | PFI24 as the source signal to rout.
JY5321A_Signal_PFI_25 | PFI25 as the source signal to rout.
JY5321A_Signal_PFI_26 | PFI26 as the source signal to rout.
JY5321A_Signal_PFI_27 | PFI27 as the source signal to rout.
JY5321A_Signal_PFI_28 | PFI28 as the source signal to rout.
JY5321A_Signal_PFI_29 | PFI29 as the source signal to rout.
JY5321A_Signal_PFI_30 | PFI30 as the source signal to rout.
JY5321A_Signal_PFI_31 | PFI31 as the source signal to rout.
JY5321A_Signal_PXI_Trig_0 |
JY5321A_Signal_PXI_Trig_1 |
JY5321A_Signal_PXI_Trig_2 |
JY5321A_Signal_PXI_Trig_3 |
JY5321A_Signal_PXI_Trig_4 |
JY5321A_Signal_PXI_Trig_5 |
JY5321A_Signal_PXI_Trig_6 |
JY5321A_Signal_PXI_Trig_7 |
JY5321A_AI_StartTrig |
JY5321A_AI_ReferenceTrig |
JY5321A_AI_SyncSignal |
JY5321A_AI_SampleClock |
JY5321A_CIO_0_StartTrig |
JY5321A_CIO_1_StartTrig |
JY5321A_CI0_SampleClock |
JY5321A_CI1_SampleClock |
JY5321A_CO_0_Output |
JY5321A_CO_1_Output |
JY5321A_CIO_100MHz |
JY5321A_CIO_5MHz |
JY5321A_CIO_100kHz |
JY5321A_AnalogTrigger |
JY5321A_DI_SampleClock |
JY5321A_DI_StartTrig |
JY5321A_DI_ReferenceTrig |
JY5321A_DO_SampleClock |
JY5321A_DO_StartTrig |

◆ JY5321A_TriggerMode

enum JY5321A_TriggerMode
Enumerator
JY5321A_StartTrigger | Start trigger mode.
JY5321A_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY5321A_AI_CheckBufferStatus()

JY5321A_API int JY5321A_AI_CheckBufferStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5321A_AI_EnableChannel()

JY5321A_API int JY5321A_AI_EnableChannel | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY5321A_AI_BandWidth * | bandWidth )

Enable AI channels. Each channel can be independently configured.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
bandWidth | array[channelCount] of bandwidth for each channel, default 25KHz. Invalid for 5321 5311 5321B 5311B
Returns
0 if success or other error code

◆ JY5321A_AI_GetRawDataWidth()

JY5321A_API int JY5321A_AI_GetRawDataWidth | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AI_RawDataWidth * | rawDataWidth )

Get Raw Data Width.

Parameters
hDevice | device handle
rawDataWidth | raw data width
Returns
0 if success or other error code

◆ JY5321A_AI_GetSamplingInfo()

JY5321A_API int JY5321A_AI_GetSamplingInfo | ( | JY5321A_DeviceHandle | hDevice,
 |  | double * | convertClockRate,
 |  | int * | oversamplingRatio,
 |  | double * | groupDelay )

Set groupDelay.

Parameters
hDevice | device handle
convertClockRate | AI conversion clock rate
oversamplingRatio | AI oversampling ratio
groupDelay | unit:sample
Returns
0 if success or other error code

◆ JY5321A_AI_GetScalingCoefficients()

JY5321A_API int JY5321A_AI_GetScalingCoefficients | ( | JY5321A_DeviceHandle | hDevice,
 |  | ScalingCoefficients | coefOfEnabledChannels[],
 |  | int | enabledChannelCount )

Get Scaling Coefficients.

Parameters
hDevice | device handle
coefOfEnabledChannels | scaling coefficients of enabled channels
enabledChannelCount | enabled channel count
Returns
0 if success or other error code

◆ JY5321A_AI_ReadData()

JY5321A_API int JY5321A_AI_ReadData | ( | JY5321A_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.

Parameters
hDevice device handle

Parameters
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5321A_AI_ReadRawData_I16()

JY5321A_API int JY5321A_AI_ReadRawData_I16 | ( | JY5321A_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5321A_AI_ReadRawData_I32()

JY5321A_API int JY5321A_AI_ReadRawData_I32 | ( | JY5321A_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer. For the multi-channel acquisition, the data is interleaved in the order defined by JY5321A_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5321A_AI_ReadRawSinglePoint()

JY5321A_API int JY5321A_AI_ReadRawSinglePoint | ( | JY5321A_DeviceHandle | hDevice,
 |  | int * | readValue,
 |  | int | channelID )

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5321A_AI_ReadSinglePoint()

JY5321A_API int JY5321A_AI_ReadSinglePoint | ( | JY5321A_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID )

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5321A_AI_ResetAnalogTriggerConfig()

JY5321A_API int JY5321A_AI_ResetAnalogTriggerConfig ( JY5321A_DeviceHandle hDevice )

Reset AI Analog Trigger config.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_AI_SendSoftTrigger()

JY5321A_API int JY5321A_AI_SendSoftTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_TriggerMode | triggerMode )

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogComparatorByEdge()

JY5321A_API int JY5321A_AI_SetAnalogComparatorByEdge | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource * | triggerSource,
 |  | double * | threshold,
 |  | JY5321A_AnalogTriggerEdge * | edges,
 |  | unsigned int | length,
 |  | JY5321A_MultiChannelCompositionLogic | resultLogic )

This function sets up the analog comparator on the device.

Parameters
hDevice | A handle to the device on which the analog comparator is being configured.
triggerSource | A pointer to an array or structure that specifies the source of the analog signal used for triggering. This could refer to a specific channel or signal input on the device.
threshold | A pointer to the threshold value (double) that will be used by the comparator. The comparator will activate when the signal exceeds or falls below this threshold, depending on the edge configuration.
edges | A pointer to the analog trigger edge configuration array.
length | The number of trigger sources (e.g., the number of channels) that are being configured.
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogComparatorByHysteresis()

JY5321A_API int JY5321A_AI_SetAnalogComparatorByHysteresis | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource * | triggerSource,
 |  | double * | highThreshold,
 |  | double * | lowThreshold,
 |  | JY5321A_AnalogTriggerEdge * | edges,
 |  | unsigned int | length,
 |  | JY5321A_MultiChannelCompositionLogic | resultLogic )

This function sets up the analog comparator to trigger when the signal enters or exits a specified window.

Parameters
hDevice | A handle to the device on which the analog comparator is being configured.
triggerSource | A pointer to an array or structure that specifies the source of the analog signal used for triggering. This could refer to a specific channel or signal input on the device.
highThreshold | A pointer to the high threshold value (double)
lowThreshold | A pointer to the low threshold value (double)
edges | A pointer to the analog trigger edge configuration array.
length | The number of trigger sources (e.g., the number of channels) that are being configured.
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogComparatorByWindow()

JY5321A_API int JY5321A_AI_SetAnalogComparatorByWindow | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource * | triggerSource,
 |  | double * | highThreshold,
 |  | double * | lowThreshold,
 |  | JY5321A_AnalogWindowCondition * | conditions,
 |  | unsigned int | length,
 |  | JY5321A_MultiChannelCompositionLogic | resultLogic )

This function sets up the analog comparator to trigger when the signal enters or exits a specified window.

Parameters
hDevice | A handle to the device on which the analog comparator is being configured.
triggerSource | A pointer to an array or structure that specifies the source of the analog signal used for triggering. This could refer to a specific channel or signal input on the device.
highThreshold | A pointer to the high threshold value (double)
lowThreshold | A pointer to the low threshold value (double)
conditions | A pointer to the analog window condition configuration array.
length | The number of trigger sources (e.g., the number of channels) that are being configured.
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogEdgeReferenceTrigger()

JY5321A_API int JY5321A_AI_SetAnalogEdgeReferenceTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerEdge | AI analog trigger edge
threshold | threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogEdgeStartTrigger()

JY5321A_API int JY5321A_AI_SetAnalogEdgeStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerEdge | AI analog trigger edge
threshold | threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogHysteresisReferenceTrigger()

JY5321A_API int JY5321A_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerEdge | AI analog trigger edge
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogHysteresisStartTrigger()

JY5321A_API int JY5321A_AI_SetAnalogHysteresisStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerEdge is defined by enum JY5321A_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerEdge | AI analog trigger edge
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogTriggerMultiChannelMode()

JY5321A_API int JY5321A_AI_SetAnalogTriggerMultiChannelMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool | enableMultiChannelTriggerMode,
 |  | JY5321A_MultiChannelCompositionLogic | resultLogic )

Enable the trigger mode for multiple channels. If this mode is enabled, multiple channels participate in trigger comparison. If this mode is disabled, single channel participates in trigger comparison.

Parameters
hDevice | device handle
enableMultiChannelTriggerMode | Enable the trigger mode for multiple channels<
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogWindowReferenceTrigger()

JY5321A_API int JY5321A_AI_SetAnalogWindowReferenceTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window reference trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerCondition is defined by enum JY5321A_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-16<
triggerCondition | AI analog trigger condition
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetAnalogWindowStartTrigger()

JY5321A_API int JY5321A_AI_SetAnalogWindowStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AnalogTriggerSource | triggerSource,
 |  | JY5321A_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JY5321A_AnalogTriggerSource, the triggerCondition is defined by enum JY5321A_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16
triggerCondition | AI analog trigger condition
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5321A_AI_SetDigitalReferenceTrigger()

JY5321A_API int JY5321A_AI_SetDigitalReferenceTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge,
 |  | bool | invertInput )

Set AI digital reference trigger.the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
invertInput | true to invert trigger input, false to use normal polarity
Returns
0 if success or other error code

◆ JY5321A_AI_SetDigitalStartTrigger()

JY5321A_API int JY5321A_AI_SetDigitalStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge,
 |  | bool | invertInput )

Set AI digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
invertInput | true to invert trigger input, false to use normal polarity
Returns
0 if success or other error code

◆ JY5321A_AI_SetDSMode()

JY5321A_API int JY5321A_AI_SetDSMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool | enable )

Set AI DSMode enable,if enable, the AI bandwidth must be 220KHz for 5321 5311 5321B 5311B. default : disable(false).

Parameters
hDevice | device handle
enable | true: enable oversample; false: disable oversample
Returns
0 if success or other error code

◆ JY5321A_AI_SetMode()

JY5321A_API int JY5321A_AI_SetMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5321A_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5321A_AI_SetPreTriggerSamples()

JY5321A_API int JY5321A_AI_SetPreTriggerSamples | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5321A_AI_SetRawDataWidth()

JY5321A_API int JY5321A_AI_SetRawDataWidth | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AI_RawDataWidth | rawDataWidth )

Set Raw Data Width.

Parameters
hDevice | device handle
rawDataWidth | raw data width
Returns
0 if success or other error code

◆ JY5321A_AI_SetReferenceTriggerType()

JY5321A_API int JY5321A_AI_SetReferenceTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AI_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5321A_AI_SetReTriggerCount()

JY5321A_API int JY5321A_AI_SetReTriggerCount | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount )

Set AI retrigger count. The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5321A_AI_SetSampleClock()

JY5321A_API int JY5321A_AI_SetSampleClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_SampleClockSource | clockSource,
 |  | JY5321A_ExternalSampleClockTerminal | terminal,
 |  | double | expectedRate )

Set AI sampling clock. the source of the sampling clock defined by enum JY5321A_SampleClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5321A_AI_SetSampleRate()

JY5321A_API int JY5321A_AI_SetSampleRate | ( | JY5321A_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate. The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5321A_AI_SetSamplesToAcquire()

JY5321A_API int JY5321A_AI_SetSamplesToAcquire | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 256M samples / channelCount.
Returns
0 if success or other error code

◆ JY5321A_AI_SetStartTriggerType()

JY5321A_API int JY5321A_AI_SetStartTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_AI_TriggerType | triggerType )

Set AI start trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5321A_AI_Start()

JY5321A_API int JY5321A_AI_Start ( JY5321A_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_AI_Stop()

JY5321A_API int JY5321A_AI_Stop ( JY5321A_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_AI_WaitUntilDone()

JY5321A_API int JY5321A_AI_WaitUntilDone | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool * | done )

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true:completed, false:not yet completed.
Returns
0 if success or other error code

◆ JY5321A_CI_CheckBufferStatus()

JY5321A_API int JY5321A_CI_CheckBufferStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5321A_CI_EnableChannel()

JY5321A_API int JY5321A_CI_EnableChannel | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.There are 2 counter.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5321A_CI_ReadCountValues()

JY5321A_API int JY5321A_CI_ReadCountValues | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the count values, this API is supprot CI Type ：JY5321A_CI_EdgeCount、JY5321A_CI_EncoderX1、 JY5321A_CI_EncoderX2 、 JY5321A_CI_EncoderX4 、JY5321A_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5321A_CI_ReadMeasureValues()

JY5321A_API int JY5321A_CI_ReadMeasureValues | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the measured values, this API only support CI Type for JY5321A_CI_Measure_EdgeSeparation JY5321A_CI_Measure_Pulse JY5321A_CI_Measure_Frequency JY5321A_CI_Measure_Period JY5321A_CI_Measure_SemiPeriod for JY5321A_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s. for JY5321A_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5321A_CI_Measure_SemiPeriod type, the measureValues1 is signal period, the unit is s,the measureValues2 invalid. for JY5321A_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5321A_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5321A_CI_Measure_Period type and JY5321A_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues1 | first measurement buffer. The buffer size must be greater than or equal to dataLength
measureValues2 | second measurement buffer. The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5321A_CI_ReadSingleCountValue()

JY5321A_API int JY5321A_CI_ReadSingleCountValue | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JY5321A_CI_EdgeCount、JY5321A_CI_EncoderX1、 JY5321A_CI_EncoderX2 、 JY5321A_CI_EncoderX4 、JY5321A_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5321A_CI_ReadSingleMeasureValue()

JY5321A_API int JY5321A_CI_ReadSingleMeasureValue | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows. for JY5321A_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5321A_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5321A_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5321A_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5321A_CI_SendSoftTrigger()

JY5321A_API int JY5321A_CI_SendSoftTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5321A_CI_SetAuxTerminal()

JY5321A_API int JY5321A_CI_SetAuxTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | auxTerminal )

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY5321A_CI_SetCounterParament()

JY5321A_API int JY5321A_CI_SetCounterParament | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5321A_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5321A_CountDirection
Returns
0 if success or other error code

◆ JY5321A_CI_SetCounterType()

JY5321A_API int JY5321A_CI_SetCounterType | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5321A_CI_MeasureType
Returns
0 if success or other error code

◆ JY5321A_CI_SetDigitalStartTrigger()

JY5321A_API int JY5321A_CI_SetDigitalStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5321A_CI_SetEdgeCountEvent()

JY5321A_API int JY5321A_CI_SetEdgeCountEvent | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold,
 |  | bool | reset )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
reset | reset count value to initialCount if ture. if false, the counter continuous count.
Returns
0 if success or other error code

◆ JY5321A_CI_SetFirstSampleClock()

JY5321A_API int JY5321A_CI_SetFirstSampleClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set the first sample clock data ignore or not.

Parameters
hDevice | device handle
channel | counter input channel
ignore | ignore the first sample clock data. true : ignore; false: not ignore
Returns
0 if success or other error code

◆ JY5321A_CI_SetGateTerminal()

JY5321A_API int JY5321A_CI_SetGateTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY5321A_CI_SetMode()

JY5321A_API int JY5321A_CI_SetMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_SampleMode | mode )

Set counter input mode, the mode is defined by enum JY5321A_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5321A_CI_SetOutTerminal()

JY5321A_API int JY5321A_CI_SetOutTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5321A_CI_SetPauseTriggerLevel()

JY5321A_API int JY5321A_CI_SetPauseTriggerLevel | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5321A_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5321A_CI_SetPauseTriggerTerminal()

JY5321A_API int JY5321A_CI_SetPauseTriggerTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | pauseTriggerTerminal )

Set CI pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY5321A_CI_SetSampleClock()

JY5321A_API int JY5321A_CI_SetSampleClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_SampleClock | clock,
 |  | JY5321A_ExternalSampleClockTerminal | terminal,
 |  | double | rate )

Set counter input sampling clock source. If the clockType is internal, user need to define sampleRate, if the clockType is JY5321A_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clock | counter input clock type. Option: internal clock, implicit clock, external clock.
terminal | external clock terminal,defined by enum JY5321A_ExternalSampleClockTerminal
rate | external clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5321A_CI_SetSamplesToAcquire()

JY5321A_API int JY5321A_CI_SetSamplesToAcquire | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire )

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5321A_CI_SetSignalReverse()

JY5321A_API int JY5321A_CI_SetSignalReverse | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5321A_CI_SetSourceTerminal()

JY5321A_API int JY5321A_CI_SetSourceTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5321A_CI_SetStartingEdge()

JY5321A_API int JY5321A_CI_SetStartingEdge | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_StartingEdge | startingEdge )

Set starting edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | starting edge.
Returns
0 if success or other error code

◆ JY5321A_CI_SetStartTriggerType()

JY5321A_API int JY5321A_CI_SetStartTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_CIO_TriggerType | triggerType )

Set CI start trigger type,the triggerType is defined by enum JY5321A_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5321A_CI_SetTimeBase()

JY5321A_API int JY5321A_CI_SetTimeBase | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CountTimeBase | timebaseSrc,
 |  | JY5321A_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set counter input time base,the time base defined by enum JY5321A_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5321A_InputTerminal.
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5321A_CI_SetValueReturnMode()

JY5321A_API int JY5321A_CI_SetValueReturnMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CI_ValueReturnMode | mode )

Config CI return value mode, only for JY5321A_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JY5321A_CI_SetZReloadEnabled()

JY5321A_API int JY5321A_CI_SetZReloadEnabled | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5321A_CI_Start()

JY5321A_API int JY5321A_CI_Start | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5321A_CI_Stop()

JY5321A_API int JY5321A_CI_Stop | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5321A_Close()

JY5321A_API int JY5321A_Close ( JY5321A_DeviceHandle hDevice )

Close this 5321A board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_CO_CheckBufferStatus()

JY5321A_API int JY5321A_CO_CheckBufferStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5321A_CO_CheckCounterStatus()

JY5321A_API int JY5321A_CO_CheckCounterStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow )

Check counter output status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
underflow | true:underflow, false:not underflow.
Returns
0 if success or other error code

◆ JY5321A_CO_EnableChannel()

JY5321A_API int JY5321A_CO_EnableChannel | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5321A_CO_SendSoftTrigger()

JY5321A_API int JY5321A_CO_SendSoftTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5321A_CO_SetCounterParament()

JY5321A_API int JY5321A_CO_SetCounterParament | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5321A_CO_IdleState | IdleState,
 |  | double | delay )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5321A_CO_SetDigitalStartTrigger()

JY5321A_API int JY5321A_CO_SetDigitalStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge )

Set CO digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5321A_CO_SetFrequency()

JY5321A_API int JY5321A_CO_SetFrequency | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, default:timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, default:timebase is 100MHz.
Returns
0 if success or other error code

◆ JY5321A_CO_SetFrequencyOnFly()

JY5321A_API int JY5321A_CO_SetFrequencyOnFly | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set the output pulse frequency of the counter in real time. After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, timebase is 100MHz.
Returns
0 if success or other error code

◆ JY5321A_CO_SetGateTerminal()

JY5321A_API int JY5321A_CO_SetGateTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | gateTerminal )

Set CO gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | source terminal
Returns
0 if success or other error code

◆ JY5321A_CO_SetMode()

JY5321A_API int JY5321A_CO_SetMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CO_OUTMode | mode )

Set counter output mode, the mode defined by enum JY5321A_CO_UpdateMode.

Parameters
hDevice | device handle
channel | counter output channel
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5321A_CO_SetOutTerminal()

JY5321A_API int JY5321A_CO_SetOutTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_Signal_Destination | outTerminal )

Set CO out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5321A_CO_SetPauseTriggerLevel()

JY5321A_API int JY5321A_CO_SetPauseTriggerLevel | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5321A_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5321A_CO_SetPauseTriggerOutState()

JY5321A_API int JY5321A_CO_SetPauseTriggerOutState | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CO_PauseTrigger_OutState | outState )

Config CO out state when pause trigger valid.

Parameters
hDevice | Device handle
channel | Counter channel
outState | out state when pause trigger valid
Returns
Succeed: 0 , Error: !=0

◆ JY5321A_CO_SetPauseTriggerTerminal()

JY5321A_API int JY5321A_CO_SetPauseTriggerTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | pauseTriggerTerminal )

Set CO Pause Trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pauseTrigger terminal
Returns
0 if success or other error code

◆ JY5321A_CO_SetSamplesToUpdate()

JY5321A_API int JY5321A_CO_SetSamplesToUpdate | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate )

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
samplesToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5321A_CO_SetSourceTerminal()

JY5321A_API int JY5321A_CO_SetSourceTerminal | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_InputTerminal | sourceTerminal )

Set CO source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5321A_CO_SetStartTriggerType()

JY5321A_API int JY5321A_CO_SetStartTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5321A_CIO_TriggerType | triggerTyp )

Set CO start trigger type,the triggerType is defined by enum JY5321A_AI_TriggerType.

Parameters
hDevice | device handle
channel | counter channel
triggerTyp | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5321A_CO_SetTimeBase()

JY5321A_API int JY5321A_CO_SetTimeBase | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5321A_CountTimeBase | timebaseSrc,
 |  | JY5321A_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set counter output time base,the time base defined by enum JY5321A_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5321A_InputTerminal.
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY5321A_CO_Start()

JY5321A_API int JY5321A_CO_Start | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5321A_CO_Stop()

JY5321A_API int JY5321A_CO_Stop | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5321A_CO_WaitUntilDone()

JY5321A_API int JY5321A_CO_WaitUntilDone | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done )

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5321A_CO_WriteData()

JY5321A_API int JY5321A_CO_WriteData | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5321A_DI_AddLines()

JY5321A_API int JY5321A_DI_AddLines | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing lineIDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5321A_DI_CheckBufferStatus()

JY5321A_API int JY5321A_DI_CheckBufferStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5321A_DI_ReadData()

JY5321A_API int JY5321A_DI_ReadData | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read DI data. The data type is short. There are independent 32 lines independently controlled, from 0 to 31.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

◆ JY5321A_DI_ReadSinglePoint()

JY5321A_API int JY5321A_DI_ReadSinglePoint | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values,when the lineID is - 1, read all enabled row values(enabled channels in function JY5321A_DI_AddLines), and store the values in the add order of the line
lineID | line number
Returns
0 if success or other error code

◆ JY5321A_DI_ReadSinglePoint_U16()

JY5321A_API int JY5321A_DI_ReadSinglePoint_U16 | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned short * | readValue )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValue | read the current 16-line digital input value
Returns
0 if success or other error code

◆ JY5321A_DI_SendSoftTrigger()

JY5321A_API int JY5321A_DI_SendSoftTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_TriggerMode | triggerMode )

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger
Returns
0 if success or other error code

◆ JY5321A_DI_SetDigitalReferenceTrigger()

JY5321A_API int JY5321A_DI_SetDigitalReferenceTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI reference trigger source
triggerEdge | DI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5321A_DI_SetDigitalStartTrigger()

JY5321A_API int JY5321A_DI_SetDigitalStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge )

Set DI digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5321A_DI_SetMode()

JY5321A_API int JY5321A_DI_SetMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DI_SampleMode | mode )

Set DI sampling mode.The mode defined by enum JY5321A_DI_SampleMode.

Parameters
hDevice | device handle
mode | DI sampling mode.Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5321A_DI_SetPreTriggerSamples()

JY5321A_API int JY5321A_DI_SetPreTriggerSamples | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set DI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | DI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5321A_DI_SetReferenceTriggerType()

JY5321A_API int JY5321A_DI_SetReferenceTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DI_TriggerType | triggerType )

Set DI reference trigger type,the triggerType is defined by enum JY5321A_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI reference trigger type. Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5321A_DI_SetSampleClock()

JY5321A_API int JY5321A_DI_SetSampleClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_SampleClockSource | clockSource,
 |  | JY5321A_ExternalSampleClockTerminal | terminal,
 |  | double | expectedRate )

Set DI sampling clock source. the source of the sampling clock defined by enum JY5321A_SampleClockSource If the clock source is external, need to configure external clock terminal and external clock frequency..

Parameters
hDevice | device handle
clockSource | DI sampling clock source
terminal | external clock terminal,defined by enum JY5321A_ExternalSampleClockTerminal.
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5321A_DI_SetSampleRate()

JY5321A_API int JY5321A_DI_SetSampleRate | ( | JY5321A_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set DI sampling rate. The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DI sampling rate to be set per channel
actualSampleRate | actually set DI sampling rate.actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5321A_DI_SetSamplesToAcquire()

JY5321A_API int JY5321A_DI_SetSamplesToAcquire | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | samplesToAcquire )

Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
samplesToAcquire | DI finite samples to acquire for each channelsamples range:1 to 16M samples
Returns
0 if success or other error code

◆ JY5321A_DI_SetStartTriggerType()

JY5321A_API int JY5321A_DI_SetStartTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DI_TriggerType | triggerType )

Set DI start trigger type,the triggerType is defined by enum JY5321A_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5321A_DI_Start()

JY5321A_API int JY5321A_DI_Start ( JY5321A_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_DI_Stop()

JY5321A_API int JY5321A_DI_Stop ( JY5321A_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_DI_WaitUntilDone()

JY5321A_API int JY5321A_DI_WaitUntilDone | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool * | done )

Check if DI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5321A_DisableAICalibration()

JY5321A_API int JY5321A_DisableAICalibration | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5321A_DisconnectSignalRouting()

JY5321A_API int JY5321A_DisconnectSignalRouting | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5321A_DestinationSignal
Returns
0 if success or other error code

◆ JY5321A_DO_AddLines()

JY5321A_API int JY5321A_DO_AddLines | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5321A_DO_CheckBufferStatus()

JY5321A_API int JY5321A_DO_CheckBufferStatus | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check DO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples that the buffer can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5321A_DO_SendSoftTrigger()

JY5321A_API int JY5321A_DO_SendSoftTrigger ( JY5321A_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_DO_SetDigitalStartTrigger()

JY5321A_API int JY5321A_DO_SetDigitalStartTrigger | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DigitalTriggerSource | triggerSource,
 |  | JY5321A_DigitalTriggerEdge | triggerEdge )

Set DO digital start trigger,the triggerSource is defined by enum JY5321A_DigitalTriggerSource, the triggerEdge is defined by enum JY5321A_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DO digital start trigger source
triggerEdge | DO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5321A_DO_SetMode()

JY5321A_API int JY5321A_DO_SetMode | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DO_UpdateMode | mode )

Set digital signal output mode, the mode defined by enum JY5321A_AO_UpdateMode.

Parameters
hDevice | device handle
mode | DO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5321A_DO_SetOutputCompleteState()

JY5321A_API int JY5321A_DO_SetOutputCompleteState | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_OutputCompleteState | State )

Set DO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.

Parameters
hDevice | device handle
State | output complete state
Returns
0 if success or other error code

◆ JY5321A_DO_SetSampleClock()

JY5321A_API int JY5321A_DO_SetSampleClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_SampleClockSource | clockSource,
 |  | JY5321A_ExternalSampleClockTerminal | terminal,
 |  | double | expectedRate )

Set DO sampling clock source. the source of the sampling clock defined by enum JY5321A_SampleClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | DO sampling clock source
terminal | external terminal, defined by enum JY5321A_ExternalSampleClockTerminal
expectedRate | DO external clock frequency

◆ JY5321A_DO_SetSamplesToUpdate()

JY5321A_API int JY5321A_DO_SetSamplesToUpdate | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | samplesToUpdate )

Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
samplesToUpdate | DO finite output samples, data range:1 to 16M sample.
Returns
0 if success or other error code

◆ JY5321A_DO_SetStartTriggerType()

JY5321A_API int JY5321A_DO_SetStartTriggerType | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_DO_TriggerType | triggerType )

Set DO start trigger type,the triggerType is defined by enum JY5321A_DO_TriggerType.

Parameters
hDevice | device handle
triggerType | DO start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5321A_DO_SetUpdateRate()

JY5321A_API int JY5321A_DO_SetUpdateRate | ( | JY5321A_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set DO update rate.The update rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DO update rate to be set per channel
actualSampleRate | actually set DO update rate,actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5321A_DO_Start()

JY5321A_API int JY5321A_DO_Start ( JY5321A_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_DO_Stop()

JY5321A_API int JY5321A_DO_Stop ( JY5321A_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5321A_DO_WaitUntilDone()

JY5321A_API int JY5321A_DO_WaitUntilDone | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check finite digital signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond,this parament not valid in current version
Returns
0 if success or other error code

◆ JY5321A_DO_WriteData()

JY5321A_API int JY5321A_DO_WriteData | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

DO write data. The data type is short. There are independent 32 lines independently controlled, from 0 to 31.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualWriteLength | Return value, the actual length of the data write
Returns
0 if success or other error code

◆ JY5321A_DO_WriteSinglePoint()

JY5321A_API int JY5321A_DO_WriteSinglePoint | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5321A_DI_AddLines).

Parameters
hDevice | device handle
writeValues | Writes the specified line values, and when the lineID is -1, writes all enabled line values (enabled channels in the JY5321A_DO_AddLines function), the values are stored in the order in which the ports were added
lineID | line number
Returns
0 if success or other error code

◆ JY5321A_DO_WriteSinglePoint_U16()

JY5321A_API int JY5321A_DO_WriteSinglePoint_U16 | ( | JY5321A_DeviceHandle | hDevice,
 |  | unsigned short | writeValue )

Write DO single point.The data type is ushort. There are 16 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit represents one line.

Parameters
hDevice | device handle
writeValue | wirte the all port values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY5321A_GetDeviceID()

JY5321A_API int JY5321A_GetDeviceID | ( | JY5321A_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the board ID. The 5321A is a series of boards.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5321A_GetDeviceSerialNumber()

JY5321A_API int JY5321A_GetDeviceSerialNumber | ( | JY5321A_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5321A_GetDeviceTemperature()

JY5321A_API int JY5321A_GetDeviceTemperature | ( | JY5321A_DeviceHandle | hDevice,
 |  | double * | temprature,
 |  | double * | fgpaTemprature )

get the device temprature.

Parameters
hDevice | device handle
temprature | device temprature
fgpaTemprature | FPGA temprature
Returns
0 if success or other error code

◆ JY5321A_Open()

JY5321A_API int JY5321A_Open | ( | int | slotNumber,
 |  | JY5321A_DeviceHandle * | hDevice )

Open the 5321A series boards using the slot number or the board serial number. PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5321A_OpenByAliasName()

JY5321A_API int JY5321A_OpenByAliasName | ( | const char * | aliasName,
 |  | JY5321A_DeviceHandle * | hDevice )

Open this 5321A series boards using the board alias name which is set by JYTEK utility JYDM. You can change the name using JYDM.

Parameters
aliasName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5321A_SetDeviceReferenceClock()

JY5321A_API int JY5321A_SetDeviceReferenceClock | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_ReferenceClockSource | clockSource,
 |  | JY5321A_ExternalReferenceClockTerminal | terminal,
 |  | double | refclockFrequency )

Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis. PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clockSource | ReferenceClock source defined by enum JY5321A_ReferenceClock
terminal | external reference clock terminal
refclockFrequency | external reference clock frequency
Returns
0 if success or other error code

◆ JY5321A_SetDeviceStatusLed()

JY5321A_API int JY5321A_SetDeviceStatusLed | ( | JY5321A_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5321A_SetPFIFilter()

JY5321A_API int JY5321A_SetPFIFilter | ( | JY5321A_DeviceHandle | hDevice,
 |  | int | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth )

Set the filter for the specified PFI.

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit:ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JY5321A_SignalRouting()

JY5321A_API int JY5321A_SignalRouting | ( | JY5321A_DeviceHandle | hDevice,
 |  | JY5321A_Signal_Source | sourceSignal,
 |  | JY5321A_Signal_Destination | destination,
 |  | JY5321A_OutputType | outputType,
 |  | bool | invertOutput )

Route a singal from source to destination. Both source and destination are defined by the corresponding enum Y5321A_SourceSignal and JY5321A_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
sourceSignal | source of the signal defined by enum JY5321A_SourceSignal
destination | destination of the signal defined by enum JY5321A_DestinationSignal
outputType | output Type
invertOutput | invert Output
Returns
0 if success or other error code
Generated by doxygen 1.15.0


5321A C++ API Manual: Class List

  • Files
  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C ScalingCoefficients


5321A C++ API Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
S
S
ScalingCoefficients


5321A C++ API Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
 JY5321ACore.h


5321A C++ API Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all class members with links to the classes they belong to:
  • Gain : ScalingCoefficients
  • Offset : ScalingCoefficients
  • Reserved1 : ScalingCoefficients
  • Reserved2 : ScalingCoefficients


5321A C++ API Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all variables with links to the classes they belong to:
  • Gain : ScalingCoefficients
  • Offset : ScalingCoefficients
  • Reserved1 : ScalingCoefficients
  • Reserved2 : ScalingCoefficients


5321A C++ API Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY5321A_AI_Analog : JY5321ACore.h
  • JY5321A_AI_BandWidth : JY5321ACore.h
  • JY5321A_AI_BandWidth_220K : JY5321ACore.h
  • JY5321A_AI_BandWidth_25K : JY5321ACore.h
  • JY5321A_AI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_AI_Continuous : JY5321ACore.h
  • JY5321A_AI_Digital : JY5321ACore.h
  • JY5321A_AI_EnableChannel() : JY5321ACore.h
  • JY5321A_AI_Finite : JY5321ACore.h
  • JY5321A_AI_GetRawDataWidth() : JY5321ACore.h
  • JY5321A_AI_GetSamplingInfo() : JY5321ACore.h
  • JY5321A_AI_GetScalingCoefficients() : JY5321ACore.h
  • JY5321A_AI_Immediately : JY5321ACore.h
  • JY5321A_AI_RawDataWidth : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_16bits : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_32bits : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_Auto : JY5321ACore.h
  • JY5321A_AI_ReadData() : JY5321ACore.h
  • JY5321A_AI_ReadRawData_I16() : JY5321ACore.h
  • JY5321A_AI_ReadRawData_I32() : JY5321ACore.h
  • JY5321A_AI_ReadRawSinglePoint() : JY5321ACore.h
  • JY5321A_AI_ReadSinglePoint() : JY5321ACore.h
  • JY5321A_AI_ReferenceTrig : JY5321ACore.h
  • JY5321A_AI_ResetAnalogTriggerConfig() : JY5321ACore.h
  • JY5321A_AI_SampleClock : JY5321ACore.h
  • JY5321A_AI_SampleMode : JY5321ACore.h
  • JY5321A_AI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByEdge() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByHysteresis() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByWindow() : JY5321ACore.h
  • JY5321A_AI_SetAnalogEdgeReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogEdgeStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogHysteresisReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogHysteresisStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogTriggerMultiChannelMode() : JY5321ACore.h
  • JY5321A_AI_SetAnalogWindowReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogWindowStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDigitalReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDSMode() : JY5321ACore.h
  • JY5321A_AI_SetMode() : JY5321ACore.h
  • JY5321A_AI_SetPreTriggerSamples() : JY5321ACore.h
  • JY5321A_AI_SetRawDataWidth() : JY5321ACore.h
  • JY5321A_AI_SetReferenceTriggerType() : JY5321ACore.h
  • JY5321A_AI_SetReTriggerCount() : JY5321ACore.h
  • JY5321A_AI_SetSampleClock() : JY5321ACore.h
  • JY5321A_AI_SetSampleRate() : JY5321ACore.h
  • JY5321A_AI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_AI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_AI_Single : JY5321ACore.h
  • JY5321A_AI_Soft : JY5321ACore.h
  • JY5321A_AI_Start() : JY5321ACore.h
  • JY5321A_AI_StartTrig : JY5321ACore.h
  • JY5321A_AI_Stop() : JY5321ACore.h
  • JY5321A_AI_SyncSignal : JY5321ACore.h
  • JY5321A_AI_TriggerType : JY5321ACore.h
  • JY5321A_AI_WaitUntilDone() : JY5321ACore.h
  • JY5321A_AnalogTrigger : JY5321ACore.h
  • JY5321A_AnalogTriggerEdge : JY5321ACore.h
  • JY5321A_AnalogTriggerSource : JY5321ACore.h
  • JY5321A_AnalogWindowCondition : JY5321ACore.h
  • JY5321A_And : JY5321ACore.h
  • JY5321A_AnyEdge : JY5321ACore.h
  • JY5321A_Channel_0 : JY5321ACore.h
  • JY5321A_Channel_1 : JY5321ACore.h
  • JY5321A_Channel_10 : JY5321ACore.h
  • JY5321A_Channel_11 : JY5321ACore.h
  • JY5321A_Channel_12 : JY5321ACore.h
  • JY5321A_Channel_13 : JY5321ACore.h
  • JY5321A_Channel_14 : JY5321ACore.h
  • JY5321A_Channel_15 : JY5321ACore.h
  • JY5321A_Channel_16 : JY5321ACore.h
  • JY5321A_Channel_17 : JY5321ACore.h
  • JY5321A_Channel_18 : JY5321ACore.h
  • JY5321A_Channel_19 : JY5321ACore.h
  • JY5321A_Channel_2 : JY5321ACore.h
  • JY5321A_Channel_20 : JY5321ACore.h
  • JY5321A_Channel_21 : JY5321ACore.h
  • JY5321A_Channel_22 : JY5321ACore.h
  • JY5321A_Channel_23 : JY5321ACore.h
  • JY5321A_Channel_24 : JY5321ACore.h
  • JY5321A_Channel_25 : JY5321ACore.h
  • JY5321A_Channel_26 : JY5321ACore.h
  • JY5321A_Channel_27 : JY5321ACore.h
  • JY5321A_Channel_28 : JY5321ACore.h
  • JY5321A_Channel_29 : JY5321ACore.h
  • JY5321A_Channel_3 : JY5321ACore.h
  • JY5321A_Channel_30 : JY5321ACore.h
  • JY5321A_Channel_31 : JY5321ACore.h
  • JY5321A_Channel_4 : JY5321ACore.h
  • JY5321A_Channel_5 : JY5321ACore.h
  • JY5321A_Channel_6 : JY5321ACore.h
  • JY5321A_Channel_7 : JY5321ACore.h
  • JY5321A_Channel_8 : JY5321ACore.h
  • JY5321A_Channel_9 : JY5321ACore.h
  • JY5321A_CI0_SampleClock : JY5321ACore.h
  • JY5321A_CI1_SampleClock : JY5321ACore.h
  • JY5321A_CI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_CI_Continuous : JY5321ACore.h
  • JY5321A_CI_Count_Down : JY5321ACore.h
  • JY5321A_CI_Count_External : JY5321ACore.h
  • JY5321A_CI_Count_Up : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState_High : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState_Low : JY5321ACore.h
  • JY5321A_CI_EdgeCount : JY5321ACore.h
  • JY5321A_CI_EnableChannel() : JY5321ACore.h
  • JY5321A_CI_EncoderTwoPulse : JY5321ACore.h
  • JY5321A_CI_EncoderX1 : JY5321ACore.h
  • JY5321A_CI_EncoderX2 : JY5321ACore.h
  • JY5321A_CI_EncoderX4 : JY5321ACore.h
  • JY5321A_CI_ExternalClock : JY5321ACore.h
  • JY5321A_CI_Finite : JY5321ACore.h
  • JY5321A_CI_ImplicitClock : JY5321ACore.h
  • JY5321A_CI_InternalClock : JY5321ACore.h
  • JY5321A_CI_Measure_EdgeSeparation : JY5321ACore.h
  • JY5321A_CI_Measure_FrequencyOrPeriod : JY5321ACore.h
  • JY5321A_CI_Measure_PulseWidth : JY5321ACore.h
  • JY5321A_CI_Measure_SemiPeriod : JY5321ACore.h
  • JY5321A_CI_MeasureType : JY5321ACore.h
  • JY5321A_CI_ReadCountValues() : JY5321ACore.h
  • JY5321A_CI_ReadMeasureValues() : JY5321ACore.h
  • JY5321A_CI_ReadSingleCountValue() : JY5321ACore.h
  • JY5321A_CI_ReadSingleMeasureValue() : JY5321ACore.h
  • JY5321A_CI_ReturnOneValue : JY5321ACore.h
  • JY5321A_CI_ReturnTwoValue : JY5321ACore.h
  • JY5321A_CI_SampleClock : JY5321ACore.h
  • JY5321A_CI_SampleMode : JY5321ACore.h
  • JY5321A_CI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_CI_SetAuxTerminal() : JY5321ACore.h
  • JY5321A_CI_SetCounterParament() : JY5321ACore.h
  • JY5321A_CI_SetCounterType() : JY5321ACore.h
  • JY5321A_CI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_CI_SetEdgeCountEvent() : JY5321ACore.h
  • JY5321A_CI_SetFirstSampleClock() : JY5321ACore.h
  • JY5321A_CI_SetGateTerminal() : JY5321ACore.h
  • JY5321A_CI_SetMode() : JY5321ACore.h
  • JY5321A_CI_SetOutTerminal() : JY5321ACore.h
  • JY5321A_CI_SetPauseTriggerLevel() : JY5321ACore.h
  • JY5321A_CI_SetPauseTriggerTerminal() : JY5321ACore.h
  • JY5321A_CI_SetSampleClock() : JY5321ACore.h
  • JY5321A_CI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_CI_SetSignalReverse() : JY5321ACore.h
  • JY5321A_CI_SetSourceTerminal() : JY5321ACore.h
  • JY5321A_CI_SetStartingEdge() : JY5321ACore.h
  • JY5321A_CI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_CI_SetTimeBase() : JY5321ACore.h
  • JY5321A_CI_SetValueReturnMode() : JY5321ACore.h
  • JY5321A_CI_SetZReloadEnabled() : JY5321ACore.h
  • JY5321A_CI_Single : JY5321ACore.h
  • JY5321A_CI_Start() : JY5321ACore.h
  • JY5321A_CI_StartingEdge : JY5321ACore.h
  • JY5321A_CI_Stop() : JY5321ACore.h
  • JY5321A_CI_ValueReturnMode : JY5321ACore.h
  • JY5321A_CIO_0_StartTrig : JY5321ACore.h
  • JY5321A_CIO_100kHz : JY5321ACore.h
  • JY5321A_CIO_100MHz : JY5321ACore.h
  • JY5321A_CIO_1_StartTrig : JY5321ACore.h
  • JY5321A_CIO_5MHz : JY5321ACore.h
  • JY5321A_CIO_Digital : JY5321ACore.h
  • JY5321A_CIO_Immediately : JY5321ACore.h
  • JY5321A_CIO_Soft : JY5321ACore.h
  • JY5321A_CIO_TriggerType : JY5321ACore.h
  • JY5321A_Clock_DI_SampleClock : JY5321ACore.h
  • JY5321A_Clock_DO_SampleClock : JY5321ACore.h
  • JY5321A_Close() : JY5321ACore.h
  • JY5321A_CO_0_Output : JY5321ACore.h
  • JY5321A_CO_1_Output : JY5321ACore.h
  • JY5321A_CO_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_CO_CheckCounterStatus() : JY5321ACore.h
  • JY5321A_CO_ContinuousNoWrapping : JY5321ACore.h
  • JY5321A_CO_ContinuousWrapping : JY5321ACore.h
  • JY5321A_CO_EnableChannel() : JY5321ACore.h
  • JY5321A_CO_Finite : JY5321ACore.h
  • JY5321A_CO_HighLevel : JY5321ACore.h
  • JY5321A_CO_HighOut : JY5321ACore.h
  • JY5321A_CO_HoldOn : JY5321ACore.h
  • JY5321A_CO_IdleState : JY5321ACore.h
  • JY5321A_CO_LowLevel : JY5321ACore.h
  • JY5321A_CO_LowOut : JY5321ACore.h
  • JY5321A_CO_OUTMode : JY5321ACore.h
  • JY5321A_CO_PauseTrigger_OutState : JY5321ACore.h
  • JY5321A_CO_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_CO_SetCounterParament() : JY5321ACore.h
  • JY5321A_CO_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_CO_SetFrequency() : JY5321ACore.h
  • JY5321A_CO_SetFrequencyOnFly() : JY5321ACore.h
  • JY5321A_CO_SetGateTerminal() : JY5321ACore.h
  • JY5321A_CO_SetMode() : JY5321ACore.h
  • JY5321A_CO_SetOutTerminal() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerLevel() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerOutState() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerTerminal() : JY5321ACore.h
  • JY5321A_CO_SetSamplesToUpdate() : JY5321ACore.h
  • JY5321A_CO_SetSourceTerminal() : JY5321ACore.h
  • JY5321A_CO_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_CO_SetTimeBase() : JY5321ACore.h
  • JY5321A_CO_Single : JY5321ACore.h
  • JY5321A_CO_Start() : JY5321ACore.h
  • JY5321A_CO_Stop() : JY5321ACore.h
  • JY5321A_CO_WaitUntilDone() : JY5321ACore.h
  • JY5321A_CO_WriteData() : JY5321ACore.h
  • JY5321A_CountDirection : JY5321ACore.h
  • JY5321A_CountTimeBase : JY5321ACore.h
  • JY5321A_DeviceHandle : JY5321ACore.h
  • JY5321A_DI_AddLines() : JY5321ACore.h
  • JY5321A_DI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_DI_Continuous : JY5321ACore.h
  • JY5321A_DI_Digital : JY5321ACore.h
  • JY5321A_DI_Finite : JY5321ACore.h
  • JY5321A_DI_Immediately : JY5321ACore.h
  • JY5321A_DI_ReadData() : JY5321ACore.h
  • JY5321A_DI_ReadSinglePoint() : JY5321ACore.h
  • JY5321A_DI_ReadSinglePoint_U16() : JY5321ACore.h
  • JY5321A_DI_ReferenceTrig : JY5321ACore.h
  • JY5321A_DI_SampleClock : JY5321ACore.h
  • JY5321A_DI_SampleMode : JY5321ACore.h
  • JY5321A_DI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_DI_SetDigitalReferenceTrigger() : JY5321ACore.h
  • JY5321A_DI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_DI_SetMode() : JY5321ACore.h
  • JY5321A_DI_SetPreTriggerSamples() : JY5321ACore.h
  • JY5321A_DI_SetReferenceTriggerType() : JY5321ACore.h
  • JY5321A_DI_SetSampleClock() : JY5321ACore.h
  • JY5321A_DI_SetSampleRate() : JY5321ACore.h
  • JY5321A_DI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_DI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_DI_Single : JY5321ACore.h
  • JY5321A_DI_Soft : JY5321ACore.h
  • JY5321A_DI_Start() : JY5321ACore.h
  • JY5321A_DI_StartTrig : JY5321ACore.h
  • JY5321A_DI_Stop() : JY5321ACore.h
  • JY5321A_DI_TriggerType : JY5321ACore.h
  • JY5321A_DI_WaitUntilDone() : JY5321ACore.h
  • JY5321A_DigitalTriggerEdge : JY5321ACore.h
  • JY5321A_DigitalTriggerSource : JY5321ACore.h
  • JY5321A_DisableAICalibration() : JY5321ACore.h
  • JY5321A_DisconnectSignalRouting() : JY5321ACore.h
  • JY5321A_DO_AddLines() : JY5321ACore.h
  • JY5321A_DO_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_DO_ContinuousNoWrapping : JY5321ACore.h
  • JY5321A_DO_ContinuousWrapping : JY5321ACore.h
  • JY5321A_DO_Digital : JY5321ACore.h
  • JY5321A_DO_Finite : JY5321ACore.h
  • JY5321A_DO_Immediately : JY5321ACore.h
  • JY5321A_DO_SampleClock : JY5321ACore.h
  • JY5321A_DO_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_DO_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_DO_SetMode() : JY5321ACore.h
  • JY5321A_DO_SetOutputCompleteState() : JY5321ACore.h
  • JY5321A_DO_SetSampleClock() : JY5321ACore.h
  • JY5321A_DO_SetSamplesToUpdate() : JY5321ACore.h
  • JY5321A_DO_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_DO_SetUpdateRate() : JY5321ACore.h
  • JY5321A_DO_Single : JY5321ACore.h
  • JY5321A_DO_Soft : JY5321ACore.h
  • JY5321A_DO_Start() : JY5321ACore.h
  • JY5321A_DO_StartTrig : JY5321ACore.h
  • JY5321A_DO_Stop() : JY5321ACore.h
  • JY5321A_DO_TriggerType : JY5321ACore.h
  • JY5321A_DO_UpdateMode : JY5321ACore.h
  • JY5321A_DO_WaitUntilDone() : JY5321ACore.h
  • JY5321A_DO_WriteData() : JY5321ACore.h
  • JY5321A_DO_WriteSinglePoint() : JY5321ACore.h
  • JY5321A_DO_WriteSinglePoint_U16() : JY5321ACore.h
  • JY5321A_Entering : JY5321ACore.h
  • JY5321A_External_Timebase : JY5321ACore.h
  • JY5321A_ExternalRefClock : JY5321ACore.h
  • JY5321A_ExternalReferenceClockTerminal : JY5321ACore.h
  • JY5321A_ExternalSampleClock : JY5321ACore.h
  • JY5321A_ExternalSampleClockTerminal : JY5321ACore.h
  • JY5321A_Falling : JY5321ACore.h
  • JY5321A_FallingEdge : JY5321ACore.h
  • JY5321A_FallingSlope : JY5321ACore.h
  • JY5321A_GetDeviceID() : JY5321ACore.h
  • JY5321A_GetDeviceSerialNumber() : JY5321ACore.h
  • JY5321A_GetDeviceTemperature() : JY5321ACore.h
  • JY5321A_HighLevel : JY5321ACore.h
  • JY5321A_Hold : JY5321ACore.h
  • JY5321A_IN_AI_SampleClock : JY5321ACore.h
  • JY5321A_IN_CIO_100kHz : JY5321ACore.h
  • JY5321A_IN_CIO_100MHz : JY5321ACore.h
  • JY5321A_IN_CIO_5MHz : JY5321ACore.h
  • JY5321A_IN_CO_0_Output : JY5321ACore.h
  • JY5321A_IN_CO_1_Output : JY5321ACore.h
  • JY5321A_IN_DI_SampleClock : JY5321ACore.h
  • JY5321A_IN_DO_SampleClock : JY5321ACore.h
  • JY5321A_IN_PFI0 : JY5321ACore.h
  • JY5321A_IN_PFI1 : JY5321ACore.h
  • JY5321A_IN_PFI10 : JY5321ACore.h
  • JY5321A_IN_PFI11 : JY5321ACore.h
  • JY5321A_IN_PFI12 : JY5321ACore.h
  • JY5321A_IN_PFI13 : JY5321ACore.h
  • JY5321A_IN_PFI14 : JY5321ACore.h
  • JY5321A_IN_PFI15 : JY5321ACore.h
  • JY5321A_IN_PFI16 : JY5321ACore.h
  • JY5321A_IN_PFI17 : JY5321ACore.h
  • JY5321A_IN_PFI18 : JY5321ACore.h
  • JY5321A_IN_PFI19 : JY5321ACore.h
  • JY5321A_IN_PFI2 : JY5321ACore.h
  • JY5321A_IN_PFI20 : JY5321ACore.h
  • JY5321A_IN_PFI21 : JY5321ACore.h
  • JY5321A_IN_PFI22 : JY5321ACore.h
  • JY5321A_IN_PFI23 : JY5321ACore.h
  • JY5321A_IN_PFI24 : JY5321ACore.h
  • JY5321A_IN_PFI25 : JY5321ACore.h
  • JY5321A_IN_PFI26 : JY5321ACore.h
  • JY5321A_IN_PFI27 : JY5321ACore.h
  • JY5321A_IN_PFI28 : JY5321ACore.h
  • JY5321A_IN_PFI29 : JY5321ACore.h
  • JY5321A_IN_PFI3 : JY5321ACore.h
  • JY5321A_IN_PFI30 : JY5321ACore.h
  • JY5321A_IN_PFI31 : JY5321ACore.h
  • JY5321A_IN_PFI4 : JY5321ACore.h
  • JY5321A_IN_PFI5 : JY5321ACore.h
  • JY5321A_IN_PFI6 : JY5321ACore.h
  • JY5321A_IN_PFI7 : JY5321ACore.h
  • JY5321A_IN_PFI8 : JY5321ACore.h
  • JY5321A_IN_PFI9 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig0 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig1 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig2 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig3 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig4 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig5 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig6 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig7 : JY5321ACore.h
  • JY5321A_InputTerminal : JY5321ACore.h
  • JY5321A_Inter_AI_ReferenceTrig : JY5321ACore.h
  • JY5321A_Inter_AI_SampleClock : JY5321ACore.h
  • JY5321A_Inter_AI_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CI_0_SampleClock : JY5321ACore.h
  • JY5321A_Inter_CI_1_SampleClock : JY5321ACore.h
  • JY5321A_Inter_CIO_0_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CIO_1_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CO_0_Output : JY5321ACore.h
  • JY5321A_Inter_CO_1_Output : JY5321ACore.h
  • JY5321A_Inter_Counter_0_Output : JY5321ACore.h
  • JY5321A_Inter_Counter_1_Output : JY5321ACore.h
  • JY5321A_Inter_DI_ReferenceTrig : JY5321ACore.h
  • JY5321A_Inter_DI_StartTrig : JY5321ACore.h
  • JY5321A_Inter_DO_StartTrig : JY5321ACore.h
  • JY5321A_Internal_Timebase_100K : JY5321ACore.h
  • JY5321A_Internal_Timebase_100M : JY5321ACore.h
  • JY5321A_Internal_Timebase_5M : JY5321ACore.h
  • JY5321A_InternalRefClock : JY5321ACore.h
  • JY5321A_InternalSampleClock : JY5321ACore.h
  • JY5321A_Leaving : JY5321ACore.h
  • JY5321A_LevelState : JY5321ACore.h
  • JY5321A_Logic : JY5321ACore.h
  • JY5321A_LowLevel : JY5321ACore.h
  • JY5321A_MultiChannelCompositionLogic : JY5321ACore.h
  • JY5321A_None : JY5321ACore.h
  • JY5321A_OCGate : JY5321ACore.h
  • JY5321A_Open() : JY5321ACore.h
  • JY5321A_OpenByAliasName() : JY5321ACore.h
  • JY5321A_Or : JY5321ACore.h
  • JY5321A_OutputCompleteState : JY5321ACore.h
  • JY5321A_OutputType : JY5321ACore.h
  • JY5321A_PFI0 : JY5321ACore.h
  • JY5321A_PFI0_OUT : JY5321ACore.h
  • JY5321A_PFI1 : JY5321ACore.h
  • JY5321A_PFI10 : JY5321ACore.h
  • JY5321A_PFI10_OUT : JY5321ACore.h
  • JY5321A_PFI11 : JY5321ACore.h
  • JY5321A_PFI11_OUT : JY5321ACore.h
  • JY5321A_PFI12 : JY5321ACore.h
  • JY5321A_PFI12_OUT : JY5321ACore.h
  • JY5321A_PFI13 : JY5321ACore.h
  • JY5321A_PFI13_OUT : JY5321ACore.h
  • JY5321A_PFI14 : JY5321ACore.h
  • JY5321A_PFI14_OUT : JY5321ACore.h
  • JY5321A_PFI15 : JY5321ACore.h
  • JY5321A_PFI15_OUT : JY5321ACore.h
  • JY5321A_PFI16 : JY5321ACore.h
  • JY5321A_PFI16_OUT : JY5321ACore.h
  • JY5321A_PFI17 : JY5321ACore.h
  • JY5321A_PFI17_OUT : JY5321ACore.h
  • JY5321A_PFI18 : JY5321ACore.h
  • JY5321A_PFI18_OUT : JY5321ACore.h
  • JY5321A_PFI19 : JY5321ACore.h
  • JY5321A_PFI19_OUT : JY5321ACore.h
  • JY5321A_PFI1_OUT : JY5321ACore.h
  • JY5321A_PFI2 : JY5321ACore.h
  • JY5321A_PFI20 : JY5321ACore.h
  • JY5321A_PFI20_OUT : JY5321ACore.h
  • JY5321A_PFI21 : JY5321ACore.h
  • JY5321A_PFI21_OUT : JY5321ACore.h
  • JY5321A_PFI22 : JY5321ACore.h
  • JY5321A_PFI22_OUT : JY5321ACore.h
  • JY5321A_PFI23 : JY5321ACore.h
  • JY5321A_PFI23_OUT : JY5321ACore.h
  • JY5321A_PFI24 : JY5321ACore.h
  • JY5321A_PFI24_OUT : JY5321ACore.h
  • JY5321A_PFI25 : JY5321ACore.h
  • JY5321A_PFI25_OUT : JY5321ACore.h
  • JY5321A_PFI26 : JY5321ACore.h
  • JY5321A_PFI26_OUT : JY5321ACore.h
  • JY5321A_PFI27 : JY5321ACore.h
  • JY5321A_PFI27_OUT : JY5321ACore.h
  • JY5321A_PFI28 : JY5321ACore.h
  • JY5321A_PFI28_OUT : JY5321ACore.h
  • JY5321A_PFI29 : JY5321ACore.h
  • JY5321A_PFI29_OUT : JY5321ACore.h
  • JY5321A_PFI2_OUT : JY5321ACore.h
  • JY5321A_PFI3 : JY5321ACore.h
  • JY5321A_PFI30 : JY5321ACore.h
  • JY5321A_PFI30_OUT : JY5321ACore.h
  • JY5321A_PFI31 : JY5321ACore.h
  • JY5321A_PFI31_OUT : JY5321ACore.h
  • JY5321A_PFI3_OUT : JY5321ACore.h
  • JY5321A_PFI4 : JY5321ACore.h
  • JY5321A_PFI4_OUT : JY5321ACore.h
  • JY5321A_PFI5 : JY5321ACore.h
  • JY5321A_PFI5_OUT : JY5321ACore.h
  • JY5321A_PFI6 : JY5321ACore.h
  • JY5321A_PFI6_OUT : JY5321ACore.h
  • JY5321A_PFI7 : JY5321ACore.h
  • JY5321A_PFI7_OUT : JY5321ACore.h
  • JY5321A_PFI8 : JY5321ACore.h
  • JY5321A_PFI8_OUT : JY5321ACore.h
  • JY5321A_PFI9 : JY5321ACore.h
  • JY5321A_PFI9_OUT : JY5321ACore.h
  • JY5321A_PXI_Trig0 : JY5321ACore.h
  • JY5321A_PXI_Trig1 : JY5321ACore.h
  • JY5321A_PXI_Trig2 : JY5321ACore.h
  • JY5321A_PXI_Trig3 : JY5321ACore.h
  • JY5321A_PXI_Trig4 : JY5321ACore.h
  • JY5321A_PXI_Trig5 : JY5321ACore.h
  • JY5321A_PXI_Trig6 : JY5321ACore.h
  • JY5321A_PXI_Trig7 : JY5321ACore.h
  • JY5321A_PXIe_Clk100 : JY5321ACore.h
  • JY5321A_PXITrig0_OUT : JY5321ACore.h
  • JY5321A_PXITrig1_OUT : JY5321ACore.h
  • JY5321A_PXITrig2_OUT : JY5321ACore.h
  • JY5321A_PXITrig3_OUT : JY5321ACore.h
  • JY5321A_PXITrig4_OUT : JY5321ACore.h
  • JY5321A_PXITrig5_OUT : JY5321ACore.h
  • JY5321A_PXITrig6_OUT : JY5321ACore.h
  • JY5321A_PXITrig7_OUT : JY5321ACore.h
  • JY5321A_RefClock_PFI_0 : JY5321ACore.h
  • JY5321A_RefClock_PFI_1 : JY5321ACore.h
  • JY5321A_RefClock_PFI_10 : JY5321ACore.h
  • JY5321A_RefClock_PFI_11 : JY5321ACore.h
  • JY5321A_RefClock_PFI_12 : JY5321ACore.h
  • JY5321A_RefClock_PFI_13 : JY5321ACore.h
  • JY5321A_RefClock_PFI_14 : JY5321ACore.h
  • JY5321A_RefClock_PFI_15 : JY5321ACore.h
  • JY5321A_RefClock_PFI_16 : JY5321ACore.h
  • JY5321A_RefClock_PFI_17 : JY5321ACore.h
  • JY5321A_RefClock_PFI_18 : JY5321ACore.h
  • JY5321A_RefClock_PFI_19 : JY5321ACore.h
  • JY5321A_RefClock_PFI_2 : JY5321ACore.h
  • JY5321A_RefClock_PFI_20 : JY5321ACore.h
  • JY5321A_RefClock_PFI_21 : JY5321ACore.h
  • JY5321A_RefClock_PFI_22 : JY5321ACore.h
  • JY5321A_RefClock_PFI_23 : JY5321ACore.h
  • JY5321A_RefClock_PFI_24 : JY5321ACore.h
  • JY5321A_RefClock_PFI_25 : JY5321ACore.h
  • JY5321A_RefClock_PFI_26 : JY5321ACore.h
  • JY5321A_RefClock_PFI_27 : JY5321ACore.h
  • JY5321A_RefClock_PFI_28 : JY5321ACore.h
  • JY5321A_RefClock_PFI_29 : JY5321ACore.h
  • JY5321A_RefClock_PFI_3 : JY5321ACore.h
  • JY5321A_RefClock_PFI_30 : JY5321ACore.h
  • JY5321A_RefClock_PFI_31 : JY5321ACore.h
  • JY5321A_RefClock_PFI_4 : JY5321ACore.h
  • JY5321A_RefClock_PFI_5 : JY5321ACore.h
  • JY5321A_RefClock_PFI_6 : JY5321ACore.h
  • JY5321A_RefClock_PFI_7 : JY5321ACore.h
  • JY5321A_RefClock_PFI_8 : JY5321ACore.h
  • JY5321A_RefClock_PFI_9 : JY5321ACore.h
  • JY5321A_ReferenceClockSource : JY5321ACore.h
  • JY5321A_ReferenceTrigger : JY5321ACore.h
  • JY5321A_Rising : JY5321ACore.h
  • JY5321A_RisingEdge : JY5321ACore.h
  • JY5321A_RisingSlope : JY5321ACore.h
  • JY5321A_SampleClock_PFI_0 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_1 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_10 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_11 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_12 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_13 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_14 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_15 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_16 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_17 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_18 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_19 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_2 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_20 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_21 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_22 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_23 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_24 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_25 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_26 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_27 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_28 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_29 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_3 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_30 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_31 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_4 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_5 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_6 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_7 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_8 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_9 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_0 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_1 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_2 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_3 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_4 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_5 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_6 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_7 : JY5321ACore.h
  • JY5321A_SampleClockSource : JY5321ACore.h
  • JY5321A_SetDeviceReferenceClock() : JY5321ACore.h
  • JY5321A_SetDeviceStatusLed() : JY5321ACore.h
  • JY5321A_SetPFIFilter() : JY5321ACore.h
  • JY5321A_Signal_Destination : JY5321ACore.h
  • JY5321A_Signal_PFI_0 : JY5321ACore.h
  • JY5321A_Signal_PFI_1 : JY5321ACore.h
  • JY5321A_Signal_PFI_10 : JY5321ACore.h
  • JY5321A_Signal_PFI_11 : JY5321ACore.h
  • JY5321A_Signal_PFI_12 : JY5321ACore.h
  • JY5321A_Signal_PFI_13 : JY5321ACore.h
  • JY5321A_Signal_PFI_14 : JY5321ACore.h
  • JY5321A_Signal_PFI_15 : JY5321ACore.h
  • JY5321A_Signal_PFI_16 : JY5321ACore.h
  • JY5321A_Signal_PFI_17 : JY5321ACore.h
  • JY5321A_Signal_PFI_18 : JY5321ACore.h
  • JY5321A_Signal_PFI_19 : JY5321ACore.h
  • JY5321A_Signal_PFI_2 : JY5321ACore.h
  • JY5321A_Signal_PFI_20 : JY5321ACore.h
  • JY5321A_Signal_PFI_21 : JY5321ACore.h
  • JY5321A_Signal_PFI_22 : JY5321ACore.h
  • JY5321A_Signal_PFI_23 : JY5321ACore.h
  • JY5321A_Signal_PFI_24 : JY5321ACore.h
  • JY5321A_Signal_PFI_25 : JY5321ACore.h
  • JY5321A_Signal_PFI_26 : JY5321ACore.h
  • JY5321A_Signal_PFI_27 : JY5321ACore.h
  • JY5321A_Signal_PFI_28 : JY5321ACore.h
  • JY5321A_Signal_PFI_29 : JY5321ACore.h
  • JY5321A_Signal_PFI_3 : JY5321ACore.h
  • JY5321A_Signal_PFI_30 : JY5321ACore.h
  • JY5321A_Signal_PFI_31 : JY5321ACore.h
  • JY5321A_Signal_PFI_4 : JY5321ACore.h
  • JY5321A_Signal_PFI_5 : JY5321ACore.h
  • JY5321A_Signal_PFI_6 : JY5321ACore.h
  • JY5321A_Signal_PFI_7 : JY5321ACore.h
  • JY5321A_Signal_PFI_8 : JY5321ACore.h
  • JY5321A_Signal_PFI_9 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_0 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_1 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_2 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_3 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_4 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_5 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_6 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_7 : JY5321ACore.h
  • JY5321A_Signal_Source : JY5321ACore.h
  • JY5321A_SignalRouting() : JY5321ACore.h
  • JY5321A_StartTrigger : JY5321ACore.h
  • JY5321A_TriggerMode : JY5321ACore.h
  • JY5321A_Zero : JY5321ACore.h


5321A C++ API Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enums with links to the files they belong to:

- j -

  • JY5321A_AI_BandWidth : JY5321ACore.h
  • JY5321A_AI_RawDataWidth : JY5321ACore.h
  • JY5321A_AI_SampleMode : JY5321ACore.h
  • JY5321A_AI_TriggerType : JY5321ACore.h
  • JY5321A_AnalogTriggerEdge : JY5321ACore.h
  • JY5321A_AnalogTriggerSource : JY5321ACore.h
  • JY5321A_AnalogWindowCondition : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState : JY5321ACore.h
  • JY5321A_CI_MeasureType : JY5321ACore.h
  • JY5321A_CI_SampleClock : JY5321ACore.h
  • JY5321A_CI_SampleMode : JY5321ACore.h
  • JY5321A_CI_StartingEdge : JY5321ACore.h
  • JY5321A_CI_ValueReturnMode : JY5321ACore.h
  • JY5321A_CIO_TriggerType : JY5321ACore.h
  • JY5321A_CO_IdleState : JY5321ACore.h
  • JY5321A_CO_OUTMode : JY5321ACore.h
  • JY5321A_CO_PauseTrigger_OutState : JY5321ACore.h
  • JY5321A_CountDirection : JY5321ACore.h
  • JY5321A_CountTimeBase : JY5321ACore.h
  • JY5321A_DI_SampleMode : JY5321ACore.h
  • JY5321A_DI_TriggerType : JY5321ACore.h
  • JY5321A_DigitalTriggerEdge : JY5321ACore.h
  • JY5321A_DigitalTriggerSource : JY5321ACore.h
  • JY5321A_DO_TriggerType : JY5321ACore.h
  • JY5321A_DO_UpdateMode : JY5321ACore.h
  • JY5321A_ExternalReferenceClockTerminal : JY5321ACore.h
  • JY5321A_ExternalSampleClockTerminal : JY5321ACore.h
  • JY5321A_InputTerminal : JY5321ACore.h
  • JY5321A_LevelState : JY5321ACore.h
  • JY5321A_MultiChannelCompositionLogic : JY5321ACore.h
  • JY5321A_OutputCompleteState : JY5321ACore.h
  • JY5321A_OutputType : JY5321ACore.h
  • JY5321A_ReferenceClockSource : JY5321ACore.h
  • JY5321A_SampleClockSource : JY5321ACore.h
  • JY5321A_Signal_Destination : JY5321ACore.h
  • JY5321A_Signal_Source : JY5321ACore.h
  • JY5321A_TriggerMode : JY5321ACore.h


5321A C++ API Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY5321A_AI_Analog : JY5321ACore.h
  • JY5321A_AI_BandWidth_220K : JY5321ACore.h
  • JY5321A_AI_BandWidth_25K : JY5321ACore.h
  • JY5321A_AI_Continuous : JY5321ACore.h
  • JY5321A_AI_Digital : JY5321ACore.h
  • JY5321A_AI_Finite : JY5321ACore.h
  • JY5321A_AI_Immediately : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_16bits : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_32bits : JY5321ACore.h
  • JY5321A_AI_RawDataWidth_Auto : JY5321ACore.h
  • JY5321A_AI_ReferenceTrig : JY5321ACore.h
  • JY5321A_AI_SampleClock : JY5321ACore.h
  • JY5321A_AI_Single : JY5321ACore.h
  • JY5321A_AI_Soft : JY5321ACore.h
  • JY5321A_AI_StartTrig : JY5321ACore.h
  • JY5321A_AI_SyncSignal : JY5321ACore.h
  • JY5321A_AnalogTrigger : JY5321ACore.h
  • JY5321A_And : JY5321ACore.h
  • JY5321A_AnyEdge : JY5321ACore.h
  • JY5321A_Channel_0 : JY5321ACore.h
  • JY5321A_Channel_1 : JY5321ACore.h
  • JY5321A_Channel_10 : JY5321ACore.h
  • JY5321A_Channel_11 : JY5321ACore.h
  • JY5321A_Channel_12 : JY5321ACore.h
  • JY5321A_Channel_13 : JY5321ACore.h
  • JY5321A_Channel_14 : JY5321ACore.h
  • JY5321A_Channel_15 : JY5321ACore.h
  • JY5321A_Channel_16 : JY5321ACore.h
  • JY5321A_Channel_17 : JY5321ACore.h
  • JY5321A_Channel_18 : JY5321ACore.h
  • JY5321A_Channel_19 : JY5321ACore.h
  • JY5321A_Channel_2 : JY5321ACore.h
  • JY5321A_Channel_20 : JY5321ACore.h
  • JY5321A_Channel_21 : JY5321ACore.h
  • JY5321A_Channel_22 : JY5321ACore.h
  • JY5321A_Channel_23 : JY5321ACore.h
  • JY5321A_Channel_24 : JY5321ACore.h
  • JY5321A_Channel_25 : JY5321ACore.h
  • JY5321A_Channel_26 : JY5321ACore.h
  • JY5321A_Channel_27 : JY5321ACore.h
  • JY5321A_Channel_28 : JY5321ACore.h
  • JY5321A_Channel_29 : JY5321ACore.h
  • JY5321A_Channel_3 : JY5321ACore.h
  • JY5321A_Channel_30 : JY5321ACore.h
  • JY5321A_Channel_31 : JY5321ACore.h
  • JY5321A_Channel_4 : JY5321ACore.h
  • JY5321A_Channel_5 : JY5321ACore.h
  • JY5321A_Channel_6 : JY5321ACore.h
  • JY5321A_Channel_7 : JY5321ACore.h
  • JY5321A_Channel_8 : JY5321ACore.h
  • JY5321A_Channel_9 : JY5321ACore.h
  • JY5321A_CI0_SampleClock : JY5321ACore.h
  • JY5321A_CI1_SampleClock : JY5321ACore.h
  • JY5321A_CI_Continuous : JY5321ACore.h
  • JY5321A_CI_Count_Down : JY5321ACore.h
  • JY5321A_CI_Count_External : JY5321ACore.h
  • JY5321A_CI_Count_Up : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState_High : JY5321ACore.h
  • JY5321A_CI_CounterEventSignalIdleState_Low : JY5321ACore.h
  • JY5321A_CI_EdgeCount : JY5321ACore.h
  • JY5321A_CI_EncoderTwoPulse : JY5321ACore.h
  • JY5321A_CI_EncoderX1 : JY5321ACore.h
  • JY5321A_CI_EncoderX2 : JY5321ACore.h
  • JY5321A_CI_EncoderX4 : JY5321ACore.h
  • JY5321A_CI_ExternalClock : JY5321ACore.h
  • JY5321A_CI_Finite : JY5321ACore.h
  • JY5321A_CI_ImplicitClock : JY5321ACore.h
  • JY5321A_CI_InternalClock : JY5321ACore.h
  • JY5321A_CI_Measure_EdgeSeparation : JY5321ACore.h
  • JY5321A_CI_Measure_FrequencyOrPeriod : JY5321ACore.h
  • JY5321A_CI_Measure_PulseWidth : JY5321ACore.h
  • JY5321A_CI_Measure_SemiPeriod : JY5321ACore.h
  • JY5321A_CI_ReturnOneValue : JY5321ACore.h
  • JY5321A_CI_ReturnTwoValue : JY5321ACore.h
  • JY5321A_CI_Single : JY5321ACore.h
  • JY5321A_CIO_0_StartTrig : JY5321ACore.h
  • JY5321A_CIO_100kHz : JY5321ACore.h
  • JY5321A_CIO_100MHz : JY5321ACore.h
  • JY5321A_CIO_1_StartTrig : JY5321ACore.h
  • JY5321A_CIO_5MHz : JY5321ACore.h
  • JY5321A_CIO_Digital : JY5321ACore.h
  • JY5321A_CIO_Immediately : JY5321ACore.h
  • JY5321A_CIO_Soft : JY5321ACore.h
  • JY5321A_Clock_DI_SampleClock : JY5321ACore.h
  • JY5321A_Clock_DO_SampleClock : JY5321ACore.h
  • JY5321A_CO_0_Output : JY5321ACore.h
  • JY5321A_CO_1_Output : JY5321ACore.h
  • JY5321A_CO_ContinuousNoWrapping : JY5321ACore.h
  • JY5321A_CO_ContinuousWrapping : JY5321ACore.h
  • JY5321A_CO_Finite : JY5321ACore.h
  • JY5321A_CO_HighLevel : JY5321ACore.h
  • JY5321A_CO_HighOut : JY5321ACore.h
  • JY5321A_CO_HoldOn : JY5321ACore.h
  • JY5321A_CO_LowLevel : JY5321ACore.h
  • JY5321A_CO_LowOut : JY5321ACore.h
  • JY5321A_CO_Single : JY5321ACore.h
  • JY5321A_DI_Continuous : JY5321ACore.h
  • JY5321A_DI_Digital : JY5321ACore.h
  • JY5321A_DI_Finite : JY5321ACore.h
  • JY5321A_DI_Immediately : JY5321ACore.h
  • JY5321A_DI_ReferenceTrig : JY5321ACore.h
  • JY5321A_DI_SampleClock : JY5321ACore.h
  • JY5321A_DI_Single : JY5321ACore.h
  • JY5321A_DI_Soft : JY5321ACore.h
  • JY5321A_DI_StartTrig : JY5321ACore.h
  • JY5321A_DO_ContinuousNoWrapping : JY5321ACore.h
  • JY5321A_DO_ContinuousWrapping : JY5321ACore.h
  • JY5321A_DO_Digital : JY5321ACore.h
  • JY5321A_DO_Finite : JY5321ACore.h
  • JY5321A_DO_Immediately : JY5321ACore.h
  • JY5321A_DO_SampleClock : JY5321ACore.h
  • JY5321A_DO_Single : JY5321ACore.h
  • JY5321A_DO_Soft : JY5321ACore.h
  • JY5321A_DO_StartTrig : JY5321ACore.h
  • JY5321A_Entering : JY5321ACore.h
  • JY5321A_External_Timebase : JY5321ACore.h
  • JY5321A_ExternalRefClock : JY5321ACore.h
  • JY5321A_ExternalSampleClock : JY5321ACore.h
  • JY5321A_Falling : JY5321ACore.h
  • JY5321A_FallingEdge : JY5321ACore.h
  • JY5321A_FallingSlope : JY5321ACore.h
  • JY5321A_HighLevel : JY5321ACore.h
  • JY5321A_Hold : JY5321ACore.h
  • JY5321A_IN_AI_SampleClock : JY5321ACore.h
  • JY5321A_IN_CIO_100kHz : JY5321ACore.h
  • JY5321A_IN_CIO_100MHz : JY5321ACore.h
  • JY5321A_IN_CIO_5MHz : JY5321ACore.h
  • JY5321A_IN_CO_0_Output : JY5321ACore.h
  • JY5321A_IN_CO_1_Output : JY5321ACore.h
  • JY5321A_IN_DI_SampleClock : JY5321ACore.h
  • JY5321A_IN_DO_SampleClock : JY5321ACore.h
  • JY5321A_IN_PFI0 : JY5321ACore.h
  • JY5321A_IN_PFI1 : JY5321ACore.h
  • JY5321A_IN_PFI10 : JY5321ACore.h
  • JY5321A_IN_PFI11 : JY5321ACore.h
  • JY5321A_IN_PFI12 : JY5321ACore.h
  • JY5321A_IN_PFI13 : JY5321ACore.h
  • JY5321A_IN_PFI14 : JY5321ACore.h
  • JY5321A_IN_PFI15 : JY5321ACore.h
  • JY5321A_IN_PFI16 : JY5321ACore.h
  • JY5321A_IN_PFI17 : JY5321ACore.h
  • JY5321A_IN_PFI18 : JY5321ACore.h
  • JY5321A_IN_PFI19 : JY5321ACore.h
  • JY5321A_IN_PFI2 : JY5321ACore.h
  • JY5321A_IN_PFI20 : JY5321ACore.h
  • JY5321A_IN_PFI21 : JY5321ACore.h
  • JY5321A_IN_PFI22 : JY5321ACore.h
  • JY5321A_IN_PFI23 : JY5321ACore.h
  • JY5321A_IN_PFI24 : JY5321ACore.h
  • JY5321A_IN_PFI25 : JY5321ACore.h
  • JY5321A_IN_PFI26 : JY5321ACore.h
  • JY5321A_IN_PFI27 : JY5321ACore.h
  • JY5321A_IN_PFI28 : JY5321ACore.h
  • JY5321A_IN_PFI29 : JY5321ACore.h
  • JY5321A_IN_PFI3 : JY5321ACore.h
  • JY5321A_IN_PFI30 : JY5321ACore.h
  • JY5321A_IN_PFI31 : JY5321ACore.h
  • JY5321A_IN_PFI4 : JY5321ACore.h
  • JY5321A_IN_PFI5 : JY5321ACore.h
  • JY5321A_IN_PFI6 : JY5321ACore.h
  • JY5321A_IN_PFI7 : JY5321ACore.h
  • JY5321A_IN_PFI8 : JY5321ACore.h
  • JY5321A_IN_PFI9 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig0 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig1 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig2 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig3 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig4 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig5 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig6 : JY5321ACore.h
  • JY5321A_IN_PXI_Trig7 : JY5321ACore.h
  • JY5321A_Inter_AI_ReferenceTrig : JY5321ACore.h
  • JY5321A_Inter_AI_SampleClock : JY5321ACore.h
  • JY5321A_Inter_AI_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CI_0_SampleClock : JY5321ACore.h
  • JY5321A_Inter_CI_1_SampleClock : JY5321ACore.h
  • JY5321A_Inter_CIO_0_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CIO_1_StartTrig : JY5321ACore.h
  • JY5321A_Inter_CO_0_Output : JY5321ACore.h
  • JY5321A_Inter_CO_1_Output : JY5321ACore.h
  • JY5321A_Inter_Counter_0_Output : JY5321ACore.h
  • JY5321A_Inter_Counter_1_Output : JY5321ACore.h
  • JY5321A_Inter_DI_ReferenceTrig : JY5321ACore.h
  • JY5321A_Inter_DI_StartTrig : JY5321ACore.h
  • JY5321A_Inter_DO_StartTrig : JY5321ACore.h
  • JY5321A_Internal_Timebase_100K : JY5321ACore.h
  • JY5321A_Internal_Timebase_100M : JY5321ACore.h
  • JY5321A_Internal_Timebase_5M : JY5321ACore.h
  • JY5321A_InternalRefClock : JY5321ACore.h
  • JY5321A_InternalSampleClock : JY5321ACore.h
  • JY5321A_Leaving : JY5321ACore.h
  • JY5321A_Logic : JY5321ACore.h
  • JY5321A_LowLevel : JY5321ACore.h
  • JY5321A_None : JY5321ACore.h
  • JY5321A_OCGate : JY5321ACore.h
  • JY5321A_Or : JY5321ACore.h
  • JY5321A_PFI0 : JY5321ACore.h
  • JY5321A_PFI0_OUT : JY5321ACore.h
  • JY5321A_PFI1 : JY5321ACore.h
  • JY5321A_PFI10 : JY5321ACore.h
  • JY5321A_PFI10_OUT : JY5321ACore.h
  • JY5321A_PFI11 : JY5321ACore.h
  • JY5321A_PFI11_OUT : JY5321ACore.h
  • JY5321A_PFI12 : JY5321ACore.h
  • JY5321A_PFI12_OUT : JY5321ACore.h
  • JY5321A_PFI13 : JY5321ACore.h
  • JY5321A_PFI13_OUT : JY5321ACore.h
  • JY5321A_PFI14 : JY5321ACore.h
  • JY5321A_PFI14_OUT : JY5321ACore.h
  • JY5321A_PFI15 : JY5321ACore.h
  • JY5321A_PFI15_OUT : JY5321ACore.h
  • JY5321A_PFI16 : JY5321ACore.h
  • JY5321A_PFI16_OUT : JY5321ACore.h
  • JY5321A_PFI17 : JY5321ACore.h
  • JY5321A_PFI17_OUT : JY5321ACore.h
  • JY5321A_PFI18 : JY5321ACore.h
  • JY5321A_PFI18_OUT : JY5321ACore.h
  • JY5321A_PFI19 : JY5321ACore.h
  • JY5321A_PFI19_OUT : JY5321ACore.h
  • JY5321A_PFI1_OUT : JY5321ACore.h
  • JY5321A_PFI2 : JY5321ACore.h
  • JY5321A_PFI20 : JY5321ACore.h
  • JY5321A_PFI20_OUT : JY5321ACore.h
  • JY5321A_PFI21 : JY5321ACore.h
  • JY5321A_PFI21_OUT : JY5321ACore.h
  • JY5321A_PFI22 : JY5321ACore.h
  • JY5321A_PFI22_OUT : JY5321ACore.h
  • JY5321A_PFI23 : JY5321ACore.h
  • JY5321A_PFI23_OUT : JY5321ACore.h
  • JY5321A_PFI24 : JY5321ACore.h
  • JY5321A_PFI24_OUT : JY5321ACore.h
  • JY5321A_PFI25 : JY5321ACore.h
  • JY5321A_PFI25_OUT : JY5321ACore.h
  • JY5321A_PFI26 : JY5321ACore.h
  • JY5321A_PFI26_OUT : JY5321ACore.h
  • JY5321A_PFI27 : JY5321ACore.h
  • JY5321A_PFI27_OUT : JY5321ACore.h
  • JY5321A_PFI28 : JY5321ACore.h
  • JY5321A_PFI28_OUT : JY5321ACore.h
  • JY5321A_PFI29 : JY5321ACore.h
  • JY5321A_PFI29_OUT : JY5321ACore.h
  • JY5321A_PFI2_OUT : JY5321ACore.h
  • JY5321A_PFI3 : JY5321ACore.h
  • JY5321A_PFI30 : JY5321ACore.h
  • JY5321A_PFI30_OUT : JY5321ACore.h
  • JY5321A_PFI31 : JY5321ACore.h
  • JY5321A_PFI31_OUT : JY5321ACore.h
  • JY5321A_PFI3_OUT : JY5321ACore.h
  • JY5321A_PFI4 : JY5321ACore.h
  • JY5321A_PFI4_OUT : JY5321ACore.h
  • JY5321A_PFI5 : JY5321ACore.h
  • JY5321A_PFI5_OUT : JY5321ACore.h
  • JY5321A_PFI6 : JY5321ACore.h
  • JY5321A_PFI6_OUT : JY5321ACore.h
  • JY5321A_PFI7 : JY5321ACore.h
  • JY5321A_PFI7_OUT : JY5321ACore.h
  • JY5321A_PFI8 : JY5321ACore.h
  • JY5321A_PFI8_OUT : JY5321ACore.h
  • JY5321A_PFI9 : JY5321ACore.h
  • JY5321A_PFI9_OUT : JY5321ACore.h
  • JY5321A_PXI_Trig0 : JY5321ACore.h
  • JY5321A_PXI_Trig1 : JY5321ACore.h
  • JY5321A_PXI_Trig2 : JY5321ACore.h
  • JY5321A_PXI_Trig3 : JY5321ACore.h
  • JY5321A_PXI_Trig4 : JY5321ACore.h
  • JY5321A_PXI_Trig5 : JY5321ACore.h
  • JY5321A_PXI_Trig6 : JY5321ACore.h
  • JY5321A_PXI_Trig7 : JY5321ACore.h
  • JY5321A_PXIe_Clk100 : JY5321ACore.h
  • JY5321A_PXITrig0_OUT : JY5321ACore.h
  • JY5321A_PXITrig1_OUT : JY5321ACore.h
  • JY5321A_PXITrig2_OUT : JY5321ACore.h
  • JY5321A_PXITrig3_OUT : JY5321ACore.h
  • JY5321A_PXITrig4_OUT : JY5321ACore.h
  • JY5321A_PXITrig5_OUT : JY5321ACore.h
  • JY5321A_PXITrig6_OUT : JY5321ACore.h
  • JY5321A_PXITrig7_OUT : JY5321ACore.h
  • JY5321A_RefClock_PFI_0 : JY5321ACore.h
  • JY5321A_RefClock_PFI_1 : JY5321ACore.h
  • JY5321A_RefClock_PFI_10 : JY5321ACore.h
  • JY5321A_RefClock_PFI_11 : JY5321ACore.h
  • JY5321A_RefClock_PFI_12 : JY5321ACore.h
  • JY5321A_RefClock_PFI_13 : JY5321ACore.h
  • JY5321A_RefClock_PFI_14 : JY5321ACore.h
  • JY5321A_RefClock_PFI_15 : JY5321ACore.h
  • JY5321A_RefClock_PFI_16 : JY5321ACore.h
  • JY5321A_RefClock_PFI_17 : JY5321ACore.h
  • JY5321A_RefClock_PFI_18 : JY5321ACore.h
  • JY5321A_RefClock_PFI_19 : JY5321ACore.h
  • JY5321A_RefClock_PFI_2 : JY5321ACore.h
  • JY5321A_RefClock_PFI_20 : JY5321ACore.h
  • JY5321A_RefClock_PFI_21 : JY5321ACore.h
  • JY5321A_RefClock_PFI_22 : JY5321ACore.h
  • JY5321A_RefClock_PFI_23 : JY5321ACore.h
  • JY5321A_RefClock_PFI_24 : JY5321ACore.h
  • JY5321A_RefClock_PFI_25 : JY5321ACore.h
  • JY5321A_RefClock_PFI_26 : JY5321ACore.h
  • JY5321A_RefClock_PFI_27 : JY5321ACore.h
  • JY5321A_RefClock_PFI_28 : JY5321ACore.h
  • JY5321A_RefClock_PFI_29 : JY5321ACore.h
  • JY5321A_RefClock_PFI_3 : JY5321ACore.h
  • JY5321A_RefClock_PFI_30 : JY5321ACore.h
  • JY5321A_RefClock_PFI_31 : JY5321ACore.h
  • JY5321A_RefClock_PFI_4 : JY5321ACore.h
  • JY5321A_RefClock_PFI_5 : JY5321ACore.h
  • JY5321A_RefClock_PFI_6 : JY5321ACore.h
  • JY5321A_RefClock_PFI_7 : JY5321ACore.h
  • JY5321A_RefClock_PFI_8 : JY5321ACore.h
  • JY5321A_RefClock_PFI_9 : JY5321ACore.h
  • JY5321A_ReferenceTrigger : JY5321ACore.h
  • JY5321A_Rising : JY5321ACore.h
  • JY5321A_RisingEdge : JY5321ACore.h
  • JY5321A_RisingSlope : JY5321ACore.h
  • JY5321A_SampleClock_PFI_0 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_1 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_10 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_11 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_12 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_13 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_14 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_15 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_16 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_17 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_18 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_19 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_2 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_20 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_21 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_22 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_23 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_24 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_25 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_26 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_27 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_28 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_29 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_3 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_30 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_31 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_4 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_5 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_6 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_7 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_8 : JY5321ACore.h
  • JY5321A_SampleClock_PFI_9 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_0 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_1 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_2 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_3 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_4 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_5 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_6 : JY5321ACore.h
  • JY5321A_SampleClock_PXI_Trig_7 : JY5321ACore.h
  • JY5321A_Signal_PFI_0 : JY5321ACore.h
  • JY5321A_Signal_PFI_1 : JY5321ACore.h
  • JY5321A_Signal_PFI_10 : JY5321ACore.h
  • JY5321A_Signal_PFI_11 : JY5321ACore.h
  • JY5321A_Signal_PFI_12 : JY5321ACore.h
  • JY5321A_Signal_PFI_13 : JY5321ACore.h
  • JY5321A_Signal_PFI_14 : JY5321ACore.h
  • JY5321A_Signal_PFI_15 : JY5321ACore.h
  • JY5321A_Signal_PFI_16 : JY5321ACore.h
  • JY5321A_Signal_PFI_17 : JY5321ACore.h
  • JY5321A_Signal_PFI_18 : JY5321ACore.h
  • JY5321A_Signal_PFI_19 : JY5321ACore.h
  • JY5321A_Signal_PFI_2 : JY5321ACore.h
  • JY5321A_Signal_PFI_20 : JY5321ACore.h
  • JY5321A_Signal_PFI_21 : JY5321ACore.h
  • JY5321A_Signal_PFI_22 : JY5321ACore.h
  • JY5321A_Signal_PFI_23 : JY5321ACore.h
  • JY5321A_Signal_PFI_24 : JY5321ACore.h
  • JY5321A_Signal_PFI_25 : JY5321ACore.h
  • JY5321A_Signal_PFI_26 : JY5321ACore.h
  • JY5321A_Signal_PFI_27 : JY5321ACore.h
  • JY5321A_Signal_PFI_28 : JY5321ACore.h
  • JY5321A_Signal_PFI_29 : JY5321ACore.h
  • JY5321A_Signal_PFI_3 : JY5321ACore.h
  • JY5321A_Signal_PFI_30 : JY5321ACore.h
  • JY5321A_Signal_PFI_31 : JY5321ACore.h
  • JY5321A_Signal_PFI_4 : JY5321ACore.h
  • JY5321A_Signal_PFI_5 : JY5321ACore.h
  • JY5321A_Signal_PFI_6 : JY5321ACore.h
  • JY5321A_Signal_PFI_7 : JY5321ACore.h
  • JY5321A_Signal_PFI_8 : JY5321ACore.h
  • JY5321A_Signal_PFI_9 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_0 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_1 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_2 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_3 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_4 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_5 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_6 : JY5321ACore.h
  • JY5321A_Signal_PXI_Trig_7 : JY5321ACore.h
  • JY5321A_StartTrigger : JY5321ACore.h
  • JY5321A_Zero : JY5321ACore.h


5321A C++ API Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY5321A_AI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_AI_EnableChannel() : JY5321ACore.h
  • JY5321A_AI_GetRawDataWidth() : JY5321ACore.h
  • JY5321A_AI_GetSamplingInfo() : JY5321ACore.h
  • JY5321A_AI_GetScalingCoefficients() : JY5321ACore.h
  • JY5321A_AI_ReadData() : JY5321ACore.h
  • JY5321A_AI_ReadRawData_I16() : JY5321ACore.h
  • JY5321A_AI_ReadRawData_I32() : JY5321ACore.h
  • JY5321A_AI_ReadRawSinglePoint() : JY5321ACore.h
  • JY5321A_AI_ReadSinglePoint() : JY5321ACore.h
  • JY5321A_AI_ResetAnalogTriggerConfig() : JY5321ACore.h
  • JY5321A_AI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByEdge() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByHysteresis() : JY5321ACore.h
  • JY5321A_AI_SetAnalogComparatorByWindow() : JY5321ACore.h
  • JY5321A_AI_SetAnalogEdgeReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogEdgeStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogHysteresisReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogHysteresisStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogTriggerMultiChannelMode() : JY5321ACore.h
  • JY5321A_AI_SetAnalogWindowReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetAnalogWindowStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDigitalReferenceTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_AI_SetDSMode() : JY5321ACore.h
  • JY5321A_AI_SetMode() : JY5321ACore.h
  • JY5321A_AI_SetPreTriggerSamples() : JY5321ACore.h
  • JY5321A_AI_SetRawDataWidth() : JY5321ACore.h
  • JY5321A_AI_SetReferenceTriggerType() : JY5321ACore.h
  • JY5321A_AI_SetReTriggerCount() : JY5321ACore.h
  • JY5321A_AI_SetSampleClock() : JY5321ACore.h
  • JY5321A_AI_SetSampleRate() : JY5321ACore.h
  • JY5321A_AI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_AI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_AI_Start() : JY5321ACore.h
  • JY5321A_AI_Stop() : JY5321ACore.h
  • JY5321A_AI_WaitUntilDone() : JY5321ACore.h
  • JY5321A_CI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_CI_EnableChannel() : JY5321ACore.h
  • JY5321A_CI_ReadCountValues() : JY5321ACore.h
  • JY5321A_CI_ReadMeasureValues() : JY5321ACore.h
  • JY5321A_CI_ReadSingleCountValue() : JY5321ACore.h
  • JY5321A_CI_ReadSingleMeasureValue() : JY5321ACore.h
  • JY5321A_CI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_CI_SetAuxTerminal() : JY5321ACore.h
  • JY5321A_CI_SetCounterParament() : JY5321ACore.h
  • JY5321A_CI_SetCounterType() : JY5321ACore.h
  • JY5321A_CI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_CI_SetEdgeCountEvent() : JY5321ACore.h
  • JY5321A_CI_SetFirstSampleClock() : JY5321ACore.h
  • JY5321A_CI_SetGateTerminal() : JY5321ACore.h
  • JY5321A_CI_SetMode() : JY5321ACore.h
  • JY5321A_CI_SetOutTerminal() : JY5321ACore.h
  • JY5321A_CI_SetPauseTriggerLevel() : JY5321ACore.h
  • JY5321A_CI_SetPauseTriggerTerminal() : JY5321ACore.h
  • JY5321A_CI_SetSampleClock() : JY5321ACore.h
  • JY5321A_CI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_CI_SetSignalReverse() : JY5321ACore.h
  • JY5321A_CI_SetSourceTerminal() : JY5321ACore.h
  • JY5321A_CI_SetStartingEdge() : JY5321ACore.h
  • JY5321A_CI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_CI_SetTimeBase() : JY5321ACore.h
  • JY5321A_CI_SetValueReturnMode() : JY5321ACore.h
  • JY5321A_CI_SetZReloadEnabled() : JY5321ACore.h
  • JY5321A_CI_Start() : JY5321ACore.h
  • JY5321A_CI_Stop() : JY5321ACore.h
  • JY5321A_Close() : JY5321ACore.h
  • JY5321A_CO_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_CO_CheckCounterStatus() : JY5321ACore.h
  • JY5321A_CO_EnableChannel() : JY5321ACore.h
  • JY5321A_CO_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_CO_SetCounterParament() : JY5321ACore.h
  • JY5321A_CO_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_CO_SetFrequency() : JY5321ACore.h
  • JY5321A_CO_SetFrequencyOnFly() : JY5321ACore.h
  • JY5321A_CO_SetGateTerminal() : JY5321ACore.h
  • JY5321A_CO_SetMode() : JY5321ACore.h
  • JY5321A_CO_SetOutTerminal() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerLevel() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerOutState() : JY5321ACore.h
  • JY5321A_CO_SetPauseTriggerTerminal() : JY5321ACore.h
  • JY5321A_CO_SetSamplesToUpdate() : JY5321ACore.h
  • JY5321A_CO_SetSourceTerminal() : JY5321ACore.h
  • JY5321A_CO_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_CO_SetTimeBase() : JY5321ACore.h
  • JY5321A_CO_Start() : JY5321ACore.h
  • JY5321A_CO_Stop() : JY5321ACore.h
  • JY5321A_CO_WaitUntilDone() : JY5321ACore.h
  • JY5321A_CO_WriteData() : JY5321ACore.h
  • JY5321A_DI_AddLines() : JY5321ACore.h
  • JY5321A_DI_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_DI_ReadData() : JY5321ACore.h
  • JY5321A_DI_ReadSinglePoint() : JY5321ACore.h
  • JY5321A_DI_ReadSinglePoint_U16() : JY5321ACore.h
  • JY5321A_DI_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_DI_SetDigitalReferenceTrigger() : JY5321ACore.h
  • JY5321A_DI_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_DI_SetMode() : JY5321ACore.h
  • JY5321A_DI_SetPreTriggerSamples() : JY5321ACore.h
  • JY5321A_DI_SetReferenceTriggerType() : JY5321ACore.h
  • JY5321A_DI_SetSampleClock() : JY5321ACore.h
  • JY5321A_DI_SetSampleRate() : JY5321ACore.h
  • JY5321A_DI_SetSamplesToAcquire() : JY5321ACore.h
  • JY5321A_DI_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_DI_Start() : JY5321ACore.h
  • JY5321A_DI_Stop() : JY5321ACore.h
  • JY5321A_DI_WaitUntilDone() : JY5321ACore.h
  • JY5321A_DisableAICalibration() : JY5321ACore.h
  • JY5321A_DisconnectSignalRouting() : JY5321ACore.h
  • JY5321A_DO_AddLines() : JY5321ACore.h
  • JY5321A_DO_CheckBufferStatus() : JY5321ACore.h
  • JY5321A_DO_SendSoftTrigger() : JY5321ACore.h
  • JY5321A_DO_SetDigitalStartTrigger() : JY5321ACore.h
  • JY5321A_DO_SetMode() : JY5321ACore.h
  • JY5321A_DO_SetOutputCompleteState() : JY5321ACore.h
  • JY5321A_DO_SetSampleClock() : JY5321ACore.h
  • JY5321A_DO_SetSamplesToUpdate() : JY5321ACore.h
  • JY5321A_DO_SetStartTriggerType() : JY5321ACore.h
  • JY5321A_DO_SetUpdateRate() : JY5321ACore.h
  • JY5321A_DO_Start() : JY5321ACore.h
  • JY5321A_DO_Stop() : JY5321ACore.h
  • JY5321A_DO_WaitUntilDone() : JY5321ACore.h
  • JY5321A_DO_WriteData() : JY5321ACore.h
  • JY5321A_DO_WriteSinglePoint() : JY5321ACore.h
  • JY5321A_DO_WriteSinglePoint_U16() : JY5321ACore.h
  • JY5321A_GetDeviceID() : JY5321ACore.h
  • JY5321A_GetDeviceSerialNumber() : JY5321ACore.h
  • JY5321A_GetDeviceTemperature() : JY5321ACore.h
  • JY5321A_Open() : JY5321ACore.h
  • JY5321A_OpenByAliasName() : JY5321ACore.h
  • JY5321A_SetDeviceReferenceClock() : JY5321ACore.h
  • JY5321A_SetDeviceStatusLed() : JY5321ACore.h
  • JY5321A_SetPFIFilter() : JY5321ACore.h
  • JY5321A_SignalRouting() : JY5321ACore.h


5321A C++ API Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY5321A_DeviceHandle : JY5321ACore.h


5321A C++ API Manual: Main Page

5321A C++ API Manual Documentation


5321A C++ API Manual: ScalingCoefficients Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
ScalingCoefficients Struct Reference

#include <JY5321ACore.h>

Public Attributes

double | Offset
double | Gain
double | Reserved1
double | Reserved2

Member Data Documentation

◆ Gain

double ScalingCoefficients::Gain

◆ Offset

double ScalingCoefficients::Offset

◆ Reserved1

double ScalingCoefficients::Reserved1

◆ Reserved2

double ScalingCoefficients::Reserved2
The documentation for this struct was generated from the following file:
  • JY5321ACore.h


5321A C++ API Manual: Member List

  • Class List
  • Class Index
  • Class Members
ScalingCoefficients Member List

This is the complete list of members for ScalingCoefficients, including all inherited members.

Gain | ScalingCoefficients
Offset | ScalingCoefficients
Reserved1 | ScalingCoefficients
Reserved2 | ScalingCoefficients